NDKr6版本编译pthread出现错误

greatpmr 发布于 2012/02/13 11:35
阅读 1K+
收藏 0

请问,我使用NDKr6版本编译一开源跨平台的软件,里面使用了pthread的API,编译时出现'pthread_condattr_init' was not declcared in this scope. (已经包含了pthread.h头文件,但是类似pthread_*的API都会提出错误),望高手多多指教,该如何解决这类错误?谢谢!

加载中
0
w
wuning
你用的ndk版本太低了,android到2.3以上的ndk版本才支持你说的那个函数,你可以调高api level就行
情天大圣
情天大圣
我用R9版本也有这个问题,当前最新版本了哦,兄台,怎么破?
返回顶部
顶部