1
回答
ruby 安装出现错误 求帮忙

 

D:\devkit>gem install rails --no-ri --no-rdoc
Fetching: thread_safe-0.3.5.gem (100%)
Successfully installed thread_safe-0.3.5
Fetching: minitest-5.7.0.gem (100%)
Successfully installed minitest-5.7.0
Fetching: tzinfo-1.2.2.gem (100%)
Successfully installed tzinfo-1.2.2
Temporarily enhancing PATH to include DevKit...
Building native extensions.  This could take a while...
ERROR:  Error installing rails:
        ERROR: Failed to build gem native extension.

    D:/Ruby193/bin/ruby.exe -r ./siteconf20150707-10860-humcd6.rb extconf.rb
creating Makefile

make  clean
Makefile:165: *** target pattern contains no `%'.  Stop.

make
Makefile:165: *** target pattern contains no `%'.  Stop.

make failed, exit code 2

Gem files will remain installed in D:/Ruby193/lib/ruby/gems/1.9.1/gems/json-1.8.
3 for inspection.
Results logged to D:/Ruby193/lib/ruby/gems/1.9.1/extensions/x86-mingw32/1.9.1/js
on-1.8.3/gem_make.out

<无标签>
举报
LaviLiu
发帖于2年前 1回/607阅
顶部