centos6.5安装php5.5.25之后无法运行phpmyadmin

NicholasNC 发布于 2015/05/18 16:55
阅读 708
收藏 0
在编译php5.5.25时出现
configure: error: Don't know how to define struct flock on this system, set --enable-opcache=no
然后在网上找了解决方法
vi /etc/ld.so.conf     # 编辑库文件
/usr/local/lib                       # 添加该行
:wq                                  # 保存退出
ldconfig                         # 使之生效,更新动态库


这是我php安装时的configure
./configure  --prefix=/usr/local/php --with-config-file-path=/usr/local/php/etc --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql=/usr/local/mysql --with-libxml-dir=/usr/local/libxml2/ --with-png-dir=/usr/local/libpng/ --with-jpeg-dir=/usr/local/jpeg9/ --with-freetype-dir=/usr/local/freetype/ --with-gd=/usr/local/gd2/ --with-zlib-dir=/usr/local/zlib/ --with-mcrypt=/usr/local/libmcrypt/ --with-mysqli=/usr/local/mysql/bin/mysql_config --with-curl=/usr/local/curl --with-xpm-dir=/usr/lib --enable-soap --enable-mbstring=all --enable-sockets

解决了php的问题之后安装phpMyAdmin-4.4.7-all-languages.tar.gz,但是在网页打开时一输入数据库的账号密码就马上退出程序(整个火狐浏览器都退出了)

不知道有没有人遇到过?
加载中
0
NicholasNC
NicholasNC
不要执行,换成下面的那条命令
错误,查找资料后,找到了解决方法
vi /etc/ld.so.conf     # 编辑库文件
/usr/local/lib                       # 添加该行
:wq                                  # 保存退出
ldconfig                         # 使之生效,更新动态库
 
执行下面一条命令就行了:【注意,下面这条语句仅对当前命令框有用】
export LD_LIBRARY_PATH=/lib/:/usr/lib/:/usr/local/lib



0
tod_tao
tod_tao

你可以换个浏览器试试,比如:chrome

这个应该和服务器没多大关系。

0
eechen
eechen
Firefox 37 + PHP 7 + Percona 5.6 + phpMyAdmin 4.4.7 没有问题。

0
NicholasNC
NicholasNC
要求使用lamp,之前用低版本的Apache2.2.9+mysql5.0.41+php5.2.6+PHPmyadmin3.0.0是没问题的,但是用了新版本的php就出现很多问题,是不是我的安装过程出错了?
eechen
eechen
这是我编译PHP7的详细过程,你可以对比参考一下 http://my.oschina.net/eechen/blog/411534
0
NicholasNC
NicholasNC
不要执行,换成下面的那条命令
错误,查找资料后,找到了解决方法
vi /etc/ld.so.conf     # 编辑库文件
/usr/local/lib                       # 添加该行
:wq                                  # 保存退出
ldconfig                         # 使之生效,更新动态库
 
执行下面一条命令就行了:【注意,下面这条语句仅对当前命令框有用】
export LD_LIBRARY_PATH=/lib/:/usr/lib/:/usr/local/lib



返回顶部
顶部