xen源码安装时的问题

Frankey 发布于 2012/02/10 11:54
阅读 919
收藏 0
Xen
今儿上午安装在centos中源码安装xen,中间遇到个问题要安装acpica,于是从http://acpica.org/downloads/上下了个acpic,然后进入源码包的compiler,然后make的时候,遇到如下问题:
//***********************************************************************************************************
[root@localhost compiler]# make
cc -c -D_LINUX -D_GNU_SOURCE -DACPI_ASL_COMPILER -I../include -I../compiler -ansi -Wall -Wbad-function-cast -Wdeclaration-after-statement -Werror -Wformat=2 -Wmissing-declarations -Wmissing-prototypes -Wstrict-aliasing=0 -Wstrict-prototypes -Wswitch-default -Wpointer-arith -Wundef -Waddress -Waggregate-return -Wchar-subscripts -Wempty-body -Wlogical-op -Wmissing-declarations -Wmissing-field-initializers -Wmissing-parameter-type -Wnested-externs -Wold-style-declaration -Wold-style-definition -Wredundant-decls -Wtype-limits -oadfile.o ../common/adfile.c
cc1: 错误:无法识别的命令行选项“-Waddress”
cc1: 错误:无法识别的命令行选项“-Wempty-body”
cc1: 错误:无法识别的命令行选项“-Wlogical-op”
cc1: 错误:无法识别的命令行选项“-Wmissing-parameter-type”
cc1: 错误:无法识别的命令行选项“-Wold-style-declaration”
cc1: 错误:无法识别的命令行选项“-Wtype-limits”
make: *** [adfile.o] 错误 1
//************************************************************************************************************

读了源码包里的readme,各种需要软件都安了。于是我用装了个centos,再make,还是不行。出现如上错误。请高手指点
加载中
0
ExtremeTalk
ExtremeTalk
why not XenServer?
0
F
Frankey

Xenserver不是很了解啊,听说还要收费,还不如自己去写那些功能啊

0
迪克2012
迪克2012
劝你用yum来装, 不要折腾源码
返回顶部
顶部