maven报错,本机上的jdk为1.8

弧线之内 发布于 2015/11/05 17:29
阅读 3K+
收藏 0

今天刚装了maven,按照网上的教程安装好,配好环境变量以后在cmd中运行mvn,结果

  报这个错。然后度娘了一下,说是jdk版本过低,maven的版本那是3.3.3,需要1.7或以上的jdk才行,可是本机上的jdk就是1.8的啊。

   

请问该怎么解决,急,在线等~

加载中
0
wuyiw
wuyiw

http://stackoverflow.com/questions/10382929/how-to-fix-unsupported-major-minor-version-51-0-error

第一个图里面的版本51.0说明maven使用的JRE是1.7版本的, 第二个图说明你可能用JDK1.8 编译的代码, 故而出错. 可以用 mvn -version 来确认maven使用的JAVA版本.

出现这样的情况可能是环境变量里配置了多个JAVA版本, 统一改为JAVA8吧.

弧线之内
弧线之内
谢谢大哥~
0
vncn
vncn
你确定你只装了一个jdk?
弧线之内
弧线之内
在path里配置了两个jdk,还有一个是tomcat的,1.6
返回顶部
顶部