配置 spring security时,启动tomcat就报错了

卢峰 发布于 2016/10/31 11:54
阅读 370
收藏 0

各位大神好,我在配置spring security 时,按网上配置,但是一启动 tomcat 就报错了,错误信息和配置如下图

加载中
0
0
谦谦君子淑女好逑
谦谦君子淑女好逑
spring-core这个包,你看你的依赖里有没有,有的话看看有没有org.springframeworker.util.AntPathMatcher这个类,没有的话可能是版本不对。
0
这里的名字只能十个字
这里的名字只能十个字
更新一下spring-core的版本 看了下源码4.1没有setCaseSensitive
0
卢峰
卢峰

引用来自“公子千”的评论

spring-core这个包,你看你的依赖里有没有,有的话看看有没有org.springframeworker.util.AntPathMatcher这个类,没有的话可能是版本不对。
这个包,这个类都是有的
0
卢峰
卢峰

引用来自“这里的名字只能十个字”的评论

更新一下spring-core的版本 看了下源码4.1没有setCaseSensitive
难道真是版本不对吗 ?这个方法确实 没有,可spring securtity是 4.1.3的(目前最新的),难道我的spring不应该也要对应版本一样吗
0
这里的名字只能十个字
这里的名字只能十个字

引用来自“这里的名字只能十个字”的评论

更新一下spring-core的版本 看了下源码4.1没有setCaseSensitive

引用来自“我是来这里找女朋友的”的评论

难道真是版本不对吗 ?这个方法确实 没有,可spring securtity是 4.1.3的(目前最新的),难道我的spring不应该也要对应版本一样吗
版本还要看实际情况而定,spring-security和spring-core是两个项目,版本不一致很正常,如果ss用的是最新版本的话,建议你也配合spring的最新版本使用,目前是4.3.3.RELEASE,帮你看过了,最新版本是有这段方法的
返回顶部
顶部