在Ubuntu14.04上自从安装过搜狗输入法1.2.0.0056版本后无法更新输入法了,并且安装或卸载其他软件都会报错,报错如下,求救!!!

百世经纶之傲笑红尘 发布于 2016/01/03 01:39
阅读 467
收藏 0
Unpacking sogoupinyin (2.0.0.0068) over (1.2.0.0056) ...
/var/lib/dpkg/info/sogoupinyin.postrm: 7: local: OS": bad variable name
dpkg: warning: subprocess old post-removal script returned error exit status 2
dpkg: trying script from the new package instead ...
/var/lib/dpkg/tmp.ci/postrm: 7: local: OS": bad variable name
dpkg: error processing archive /var/cache/apt/archives/sogoupinyin_2.0.0.0068_amd64.deb (--unpack):
 subprocess new post-removal script returned error exit status 2
/var/lib/dpkg/tmp.ci/postrm: 7: local: OS": bad variable name
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 2
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Processing triggers for libglib2.0-0:amd64 (2.42.2-0ubuntu1~14.04~ricotz0) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1+elementary2~ubuntu14.04.1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/sogoupinyin_2.0.0.0068_amd64.deb
Error in function: 
加载中
0
百世经纶之傲笑红尘
百世经纶之傲笑红尘

昨天半夜开启暴君模式,find/ mysql 只要是老版本的,都倒在了我的屠刀下,然后debian包里面一大片依赖错误,原因:debian这个瘪孙,都不给一个依赖继承表,还得本大爷又一顿吊打debian,不得不说Ubuntu软件中心是个废物,debian 走终端安装很easy,走软件中心等着哭吧

@eechen

返回顶部
顶部