Eclipse RAP 入门(一)

晨曦之光 发布于 2012/03/09 12:11
阅读 1K+
收藏 0

由于今天刚启动学习进程, 先粗略的介绍一些环境方面的搭建。

 

Eclipse插件的使用跟官方网站有写区别, 目前采用Eclipse RCP 3.4

 

【强烈建议采用Eclipse RCP 3.5 将在一个星期内发布, 3.4不能用wizard建立HelloWorld工程, 相当失败】

 

1. 安装。

 

似乎Eclipse的插件安装都推荐采用网络Update的方式。

 

按照官网的文档【http://www.eclipse.org/rap/gettingstarted.php

 

(不用去看视频教程, 基本废掉了,对Eclipse3.4而言,误导而已)

 

Update网址:

 

http://download.eclipse.org/rt/rap/1.2/update

(如果更新有问题,可以从http://www.eclipse.org/rap/downloads/下载, 注意是最新版本)

 

重启之后,出现欢迎页面, 其中有一个Install Target platform的向导,默认安装即可。

 

 

2. 试用Demo

 

从Plug in中抽取一个RAP Demo, 步骤如下:

 

  •  打开Plug in Development Perspective, 切换到Plug ins view,
  •  选中插件:   org.eclipse.rap.demo
  • 右键import as -> source project, 则可以将其抽取成Eclipse RAP工程。

接下来,就是启动:

 

启动的方式有很多, 无论从plugin.xml, 还是Menifest.mf启动, 还是从工程启动,或者是Run as 归根到底是

 

下面的设置(从Run as 中打开的对话框):

 

RAP 图一

 

在Eclipse 3.4的版本中,这里千万不要改第一个绿色框的rap, 否则将导致不可访问。

 

【后来会发现, 可以在扩展项中,增加branding, 就可以配置成其它的Sevelet name, 并且可以有不同的主题,

 

暂时记住这一点,默认的Servelet都是rap, 就OK!】

 

第二个框是EntryPoint, 是你制定Web访问的进入点, 可以从plugin.xml中设置或者MeniFest.mf文件中设置:

 

官方Demo都有设置的方法。 不再赘述。

 

启动RAP Application 及可以访问:

 

可能会遇到两个问题:

 

1. 启动后看到一堆错误Entry错误, 提示某些ID, 最后面出现了一个BadVersion Number, 表明你需要使用

 

1.6的JRE

 

2. 启动之后控制台没问题,但打开的浏览器中出现:

 

HTTP ERROR: 404

ProxyServlet: /rap

RequestURI=/rap

Powered by Jetty://

此时可能服务器还没有准备好, 需要再次刷新访问。

3. An entry point named 'XXX' does not exist.

说明你配置的EntryPonit存在问题, 多个工程尤其要注意这个问题, 可能你运行的是A工程,而实际上

Entry Point是B工程的, 更改设置即可,很简单。

4. 出现一大堆的Unkown ID,可能是依赖bundle没有加载成功, 上图里面的bundles中,点击add required bundles,就可以了。


原文链接:http://blog.csdn.net/ostrichmyself/article/details/4271408
加载中
返回顶部
顶部