android导入项目常见问题解决

晨曦之光 发布于 2012/03/08 14:24
阅读 6K+
收藏 4

初学android,最近在使用现成的代码的过程中发现直接导入的eclipse项目大都不能直接使用,总结下出现的问题和解决方案:

1.project.properties或default. Properties的问题

   有的项目这两个问题不能在eclipse下直接打开,会提示:

                                

解决方案:

在eclipse下选择 open with->system editor,或者直接在文件夹中选择用记事本打开,如下:

打开后,需要修改“target=android-10”跟你下载的android版本对应上,这里android-10并不是android的真实版本,你懂的。看看这里就知道了,api版本后就是你需要填的了:

修改好对应的版本后,关了项目再打开,就可以看到了,第一个项目中是正常的,第二个没有对应的android api版本的东东:

2.
Description      Resource Path Location   Type

Android requires compiler compliance level5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix ProjectProperties.         AllProvidersTest                line 1         Android ADT Problem

这个问题是因为java api版本的问题引起的,我本机上用的1.7的最新版本,而现有的代码是1.6或1.5的版本。

解决方案:

选择项目,右键-Properties,如图:

勾选“ enable project specific settings”,然后选择正确的api版本,选择”apply”即可。

这样你的项目就可以使用了。


原文链接:http://blog.csdn.net/hliq5399/article/details/7101735
加载中
0
爱恒2014
爱恒2014
不错,牛逼的很
0
ldh2015
ldh2015

 

哈哈! 朋友真牛,这么细节问题都知道

0
西门飞
西门飞
第二个问题遇到过 可是JDK更改过了 又出来新的错误了  奇怪了
返回顶部
顶部