暂不支持PHP 7.0正式版的pecl扩展汇总

朱__朱 发布于 2015/12/03 14:30
阅读 2K+
收藏 1

由于php 7正式版刚刚发布,大部分pecl扩展还没有跟进到php 7正式版, 例如:


redis  xhporf solr mongo xdebug  igbinary  memcache imagick  ev  gearman mongodb  memcached phalcon

加载中
0
宏哥
宏哥

哈哈, 

我全部不用


mark35
mark35
git下来的可以make了
mark35
mark35
我正在clone这儿的 https://github.com/hightman/scws/
宏哥
宏哥
回复 @mark35 : 你需要的话, 我把代码给你
宏哥
宏哥
回复 @mark35 : 我把 scws 做成http服务
mark35
mark35
scws在php7下make失败
下一页
0
路飞
路飞

hi楼主

请问你对zookeeper有研究么,求解决方案

http://www.oschina.net/question/95699_2143880

路飞
路飞
回复 @朱__朱 : -_-!!!
朱__朱
朱__朱
没有研究过
0
Tuesday
Tuesday
还在等官方的发布, 要释放出32/64位, 还有模式
0
梦想岛
梦想岛
memcached for windows ,有没有??
OSC首席键客
OSC首席键客
这个要自己编译!
0
mark35
mark35
都没用到
0
卖爷爷的老红薯
卖爷爷的老红薯
5年后,估计主机主流框架就都升级到php7了,再说。
0
eechen
eechen
源代码主干中php7-src/ext下面的扩展已经全部支持PHP7.
对于一些没有收录到PHP主干代码的第三方PECL扩展,则需要跟进开发.
不过峰哥的Swoole,鸟哥的Yaf/Yar/Yac/Yaconf/Taint等等都已经支持PHP7了.
https://pecl.php.net/package/swoole
https://pecl.php.net/package/yaf

PHP官方肯定对WordPress这些常用的应用做过PHP7兼容性测试,用来跑最新版WordPress/Drupal等肯定是没有问题的.
eechen
eechen
Xdebug在11月发的2.4.0 beta版已经支持PHP7了: https://pecl.php.net/package/xdebug
eechen
eechen
phpredis for PHP7 也放出来了 https://github.com/phpredis/phpredis/archive/php7.zip
0
旁边白
旁边白
。。。。还在用5.2有木有,哈哈
旁边白
旁边白
回复 @fei : 低没关系,稳定就好
fei
fei
5.2确实太低了。我见到的很多eshop/ecstore的只能用5.3
0
yiane
yiane
redis 

https://github.com/phpredis/phpredis/tree/php7

mongodb

https://github.com/mongodb/mongo-php-driver/tree/PHP7

不过mongo lib没跟上

mongo看样子是打算放弃支持7?不更新了

https://pecl.php.net/package/mongo

朱__朱
朱__朱
mongo扩展不会更新了。现在mongodb扩展接力了
0
Liuxd
Liuxd

基本上主流的都不支持,吗?

朱__朱
朱__朱
mongodb,redis,xdebug,memcached应该会很快跟进完成发布到pecl。其他的难说,不过半年内主流扩展应该会跟进完成
返回顶部
顶部