intellij idea如何设置新创建module的默认laguage level和bytecode level?

粉色乃团团 发布于 2016/04/24 12:18
阅读 2K+
收藏 0
idea大神帮忙看看,拜谢!
  1. 我用的是Mac OS X,intellij idea 2016版本,装的是1.8的jdk
  2. 我先创建一个empty project,然后将project language level 调成1.8
  3. 然后在这个empty project中创建一个maven module,这个创建出来的module会自动将laguage level改成1.5(图1,图2),为什么啊?
  4. 我将settings -> java compiler明明将project bytecode version 设置成1.8,但是每个module的bytecode version 竟然也会默认成1.5(图3),为什么?
  5. 上面两个问题我知道可以通过手动去改,但是有没有哪里可以设置默认项,不用每次都去手动改?
  6. 每次创建maven项目后都会弹出一个窗口,能去掉不(图4)?

图1:

图2:

图3:

图4:

加载中
0
子允
maven的配置模板默认就是1.5,只能手动改,或者自己建新的模板。
返回顶部
顶部