cassandra 的cqlsh脚步无法使用

超级呆子 发布于 2016/07/28 10:05
阅读 989
收藏 0

安装了cassandra2.2.7   3.7, 3.0.8 这几个版本

启动cassandra没问题,但是执行cqlsh脚本都报错了,提示

Python Cassandra driver not installed, or not on PYTHONPATH.
You might try "pip install cassandra-driver".

Python: /usr/local/bin/python2.7
Module load path: ['/root/distributed/apache-cassandra-3.0.8/bin/../lib/six-1.7.3-py2.py3-none-any.zip', '/root/distributed/apache-cassandra-3.0.8/bin/../lib/futures-2.1.6-py2.py3-none-any.zip', '/root/distributed/apache-cassandra-3.0.8/bin/../lib/cassandra-driver-internal-only-3.0.0-6af642d.zip/cassandra-driver-3.0.0-6af642d', '/root/distributed/apache-cassandra-3.0.8/bin', '/usr/local/lib/python27.zip', '/usr/local/lib/python2.7', '/usr/local/lib/python2.7/plat-linux2', '/usr/local/lib/python2.7/lib-tk', '/usr/local/lib/python2.7/lib-old', '/usr/local/lib/python2.7/lib-dynload', '/usr/local/lib/python2.7/site-packages']

Error: can't decompress data; zlib not available



装了python2.7和3.4的都不行,机器是虚拟机环境centos6.5

JDK是1.8



加载中
0
hzajie
hzajie
大哥,这么明显的错误还不知道,你应该是基于她的驱动没有装吧.
炑炑milina
炑炑milina
我的python也更新了,同样的python和cassandra,同样的centos6,同样的我用同样的方式部署,其中一个环境也报这样的 错,另一个号好的
超级呆子
超级呆子
应该是把python版本更新一下就可以了,我看其他人装的时候就直接解压cassandra就可以用了。 你说的驱动是独立的python连接cassandra驱动吗?我装过一个貌似也不行。
返回顶部
顶部