有谁编译过hbase0.94?

超级呆子 发布于 2014/04/17 14:21
阅读 405
收藏 0

想用hbase0.94版本 加 hadoop2.2

直接用hadoop2.2的jar包不行,把所有的jar包都导入到hbase中,最后出了这个错误:

java.lang.NoClassDefFoundError: org/apache/hadoop/hdfs/protocol/FSConstants$SafeModeAction



这个类在hadoop2.2中根本就没有,只有1.x的版本才有,所以只能重新编译了

但是编译的时候又提示说各种类找不到

如org.apache.hadoop.fs.Path,但是导入的jar包中是有这个类的。

有哪位大侠正确编译过的,麻烦告知一下,多谢了。

加载中
0
震秦
震秦

在我的记忆中,HBase 0.94.x只支持hadoop 1.x的吧? 应该是不支持hadoop 2.x?

0.96.x 才有 for hadoop2的版本。

超级呆子
超级呆子
我看hbase官方文档上说0.94.x支持hadoop2.x的,另外现在stable的只有0.94
0
bingmengctt
bingmengctt
解决了吗?我也遇到这个问题
返回顶部
顶部