apache配置加载的模块,重启后却不能加载,但其他集成环境却可以

hero20111 发布于 2015/03/04 11:17
阅读 870
收藏 0

visual amp集成环境用Phpinfo.php检测, Server API显示的是CGI/FastCGI如下图,

apache2handler下面的详细信息,如下图 ,

这些图中有个loaded modules已经加载模块,不显示这些已经加载的模块也就是未加载成功apache相关的模块。
其他集成环境比如wamp appserv用phpinfo.php检测,Server API显示的是Apache 2.0 Handler 如下图

也就是apache已经加载成功相关的模块。

发现用Phpinfo.php中的Server API可以正常显示Apache 2.0 Handler的,在apache的配置文件里面
httpd.conf里都有这么一句  LoadModule php5_module "../php/php5apache2_4.dll"
php5的版本又分为2个,一个是None Thread Safe(NTS,非线程安全) 另一个是Thread Safe(TS,线程安全
),
nts的php版本中不含有php5apache2_4.dll这个文件,也就是不能用load module进行加载该模块,
另一个是TS版,里面有php5apache2_4.dll这个文件,按道理说可以用load module进行加载该模块来支持

回到visual amp集成环境里面,把它自带的apache的httpd.conf 中用load module加载该文件,重启
apache, Server API显示的依然是CGI/FastCGI,也就没有apache2handler下面的详细信息,如下图

也就是apache不能加载很多模块。
不知道还有啥办法可以让该visual amp来显示已经加载过的模块信息(已经配置加载过好多模块了。)

加载中
返回顶部
顶部