局域网内主机在远程服务器有gitotlite控制下,执行git clone远程时总提示输入密码

sishuiliuyun 发布于 2015/05/20 18:29
阅读 1K+
收藏 1

问题背景:

1) 在阿里云服务器上面初始化gitolite,并将服务器上的gitAdmin用户初始化为Admin用户,用来执行user和key的添加、及访问权限控制;

2)在客户端主机(处于内网,但是可通过路由器访问Internet)上建立一个远程管理员账户git

3)生产一对RSA秘钥对,命名为git.pub 和git ,并将其远程copy到阿里云服务器端

4)使用gitAdmin账户添加用户git和秘钥git.pub,并更新仓库

测试:

客户端测试) git clone git@<remote-server-ip>:testing

错误返回:

1) 提示本地用户输入登录密码

【问题】

这个问题怎么解决?

加载中
0
大培哥
大培哥
我怀疑你的问题是因为你创建git用户的时候,采用的是有密码的方式,所以你以git@XXX的方式去克隆testing的时候就会要求你去输入密码,如果你采用这种方式:sudo adduser --system --group --shell /bin/bash --disabled-password git。如果最后还不行的话可以参考:http://my.oschina.net/u/2496664/blog/528446。希望能帮到您~
返回顶部
顶部