JFinal c3p0 这是什么原因造成的?数据库的增删改查操作后无变化。

chris_hellowoo 发布于 2015/01/19 15:53
阅读 542
收藏 0

如题,c3p0数据源插件配置好了,数据库和相应表单已建立,表单与模型映射没有问题,但启动时候会出现这种红色的信息,并且访问页面对相应数据进行相关操作,数据库没有任何变化

Starting JFinal 1.9
Starting scanner at interval of 5 seconds.
Starting web server on port: 80
2015-1-19 15:44:46 com.mchange.v2.log.MLog <clinit>
信息: MLog clients using java 1.4+ standard logging.
2015-1-19 15:44:46 com.mchange.v2.c3p0.C3P0Registry banner
信息: Initializing c3p0-0.9.1.2 [built 21-May-2007 15:04:56; debug? true; trace: 10]
2015-1-19 15:44:46 com.mchange.v2.c3p0.impl.AbstractPoolBackedDataSource getPoolManager
信息: Initializing c3p0 pool... com.mchange.v2.c3p0.ComboPooledDataSource [ acquireIncrement -> 2, acquireRetryAttempts -> 30, acquireRetryDelay -> 1000, autoCommitOnClose -> false, automaticTestTable -> null, breakAfterAcquireFailure -> false, checkoutTimeout -> 0, connectionCustomizerClassName -> null, connectionTesterClassName -> com.mchange.v2.c3p0.impl.DefaultConnectionTester, dataSourceName -> 1hgef4197bhwmmz376gf|4945f939, debugUnreturnedConnectionStackTraces -> false, description -> null, driverClass -> com.mysql.jdbc.Driver, factoryClassLocation -> null, forceIgnoreUnresolvedTransactions -> false, identityToken -> 1hgef4197bhwmmz376gf|4945f939, idleConnectionTestPeriod -> 0, initialPoolSize -> 10, jdbcUrl -> jdbc:mysql://127.0.0.1/estqq?characterEncoding=utf8&zeroDateTimeBehavior=convertToNull, maxAdministrativeTaskTime -> 0, maxConnectionAge -> 0, maxIdleTime -> 20, maxIdleTimeExcessConnections -> 0, maxPoolSize -> 100, maxStatements -> 0, maxStatementsPerConnection -> 0, minPoolSize -> 10, numHelperThreads -> 3, numThreadsAwaitingCheckoutDefaultUser -> 0, preferredTestQuery -> null, properties -> {user=******, password=******}, propertyCycle -> 0, testConnectionOnCheckin -> false, testConnectionOnCheckout -> false, unreturnedConnectionTimeout -> 0, usesTraditionalReflectiveProxies -> false ]
Starting Complete. Welcome To The JFinal World :)


加载中
1
千斤难买春秋醉
千斤难买春秋醉

你发的这就是正常的info啊。

目测是你程序问题

chris_hellowoo
chris_hellowoo
已经自己解决了,是action的问题。由于数据库操作后竟然没有变化,所以我之前以为这个红色的是警告,认为是c3p0出了问题。后来debug了许久,解决了
返回顶部
顶部