有人搭建成功么?试了半天老有错

飞弹蛋 发布于 2013/04/23 13:51
阅读 800
收藏 0

亲们

D:\Django-1.4.3\django\bin\lfs-installer>python bootstrap.py
No local packages or download links found for zc.buildout
error: Could not find suitable distribution for Requirement.parse('zc.buildout')


Traceback (most recent call last):
  File "bootstrap.py", line 71, in <module>
    ) == 0
AssertionError

加载中
0
hnynes
hnynes

还好,没有难度.
看上去是你的网络环境下无法下载到zc.buildout吧.建议可以自己去下载个,解压好,放在那个egg目录下.  我的那个目录下的那个版本是2.1.0.  
还有一点,看你的目录结构,你是把这个放在了django的目录下面,其实完全没有必要,因为在你更新完后,会发现egg下面用的django居然是1.3.1的版本.(猜测而已,如有误,请勿喷.)  

飞弹蛋
飞弹蛋
python bootstrap.py 执行不成功 Make sure you have the latest version downloaded from http://downloads.buildout.org/2/bootstrap.py 我用最新的也不行
0
飞弹蛋
飞弹蛋

引用来自“hnynes”的答案

还好,没有难度.
看上去是你的网络环境下无法下载到zc.buildout吧.建议可以自己去下载个,解压好,放在那个egg目录下.  我的那个目录下的那个版本是2.1.0.  
还有一点,看你的目录结构,你是把这个放在了django的目录下面,其实完全没有必要,因为在你更新完后,会发现egg下面用的django居然是1.3.1的版本.(猜测而已,如有误,请勿喷.)  

从网上装zc.buildout的2.1.0 版本太高 导致,老有报错,换成低版本的搞定,谢谢

0
hnynes
hnynes
嗯,不错,有时间可以看看另外一个很强大的库 Mezzanine.
飞弹蛋
飞弹蛋
回复 @飞弹蛋 :
飞弹蛋
飞弹蛋
回复 @飞弹蛋 :
飞弹蛋
飞弹蛋
ok
0
shewa
shewa

貌似只有一个shop,如果想作多个shop(shopA,shopB,shopC。。。),貌似要大改把? 还是把 多个shop (shopA,shopB,shopC...)每个shop*当成一个商品呢?后者貌似不行阿。

0
shewa
shewa

貌似只有一个shop,如果想做多个shop(shopA,shopB,shopC。。。),貌似要大改把?  像taobao那样,可以让多个shop入住的那种。有人知道怎么办吗? 首先,这个多shop入住,是否可行。如果可行,给个改的大概的思路吧。如果不行,说一下理由。谢谢拉。

飞弹蛋
飞弹蛋
494514014
shewa
shewa
回复 @飞弹蛋 : 没太明白您的意思。admin登录的话,也没有用户管理菜单。 只有shop、catalog等的管理。 貌似shop是最高层的了,没看到怎么添加多个shop。 能否留个qq,方便交流一下?
飞弹蛋
飞弹蛋
admin新增用户可以 选职员状态 指明用户是否可以登录到这个管理站点。
返回顶部
顶部