perl的安装配置问题

linuxstudy 发布于 2015/01/26 10:39
阅读 574
收藏 0

@Yisen 你好,想跟你请教个问题:

在执行.configure命令时加上 --with-perl-modules -enable-embedded-perl,编译时出现下面的错误。提示要修改环境变量PERLPROG的路径。请问在哪个目录下的哪个文件修改?谢谢!

checking for Perl CFLAGS... Can't locate ExtUtils/Embed.pm in @INC (@INC contains: /usr/local/lib/perl5 /usr/local/share/perl5 /usr/local/share/perl5 /usr/lib/perl5 /usr/share/perl5 /usr/share/perl5 /usr/lib/perl5 /usr/share/perl5 /usr/local/lib/perl5/site_perl/5.10.0/i386-linux-thread-multi /usr/local/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl /usr/lib/perl5/site_perl .)
BEGIN failed--compilation aborted.
configure: error: Could not determine the C compiler flags that were used to build /usr/bin/perl. Either set the environment variable PERLPROG to a different Perl binary or use --disable-embedded-perl to turn off embedded Perl functionality altogether.

 

加载中
返回顶部
顶部