安装Weblogic12.1.3时遇到jre1.7.0_71不是有效的 JDK

姓名长度最少3个字符 发布于 2015/01/08 00:57
阅读 13K+
收藏 0
E:\weblogic>java -jar fmw_12.1.3.0.0_wls.jar
启动程序日志文件为C:\Users\megar0\AppData\Local\Temp\OraInstall2015-01-08_12-52-45
AM\launcher2015-01-08_12-52-45AM.log。
正在提取文件.............................
此安装程序必须使用 Java 开发工具包 (JDK) 执行,
但C:\Program Files\Java\jre1.7.0_71不是有效的 JDK。

按任意键以退出...

安装weblogic 12.1.3遇到如上问题,请问如何解决?非要卸载jre么?

我已经在PATH中加了环境变量了。



加载中
0
_
_Yud
使用jdk目录中的java执行试试
姓名长度最少3个字符
姓名长度最少3个字符
额,确实是这样的。使用了jdk里的java,就OK了!真是奇葩。
0
天神下凡
天神下凡
楼主能说详细点不,我跟你同样的问题,搞不定啊,谢谢了
姓名长度最少3个字符
姓名长度最少3个字符
是这样的,根据Oralce的Certification Matrix,WLS12.1.3要求1.7.0_51+的JDK才可以。所以,升级你的JDK吧。
0
0
s
stackport
把fmw_12.1.3.0.0_wls.jar放到%JAVA_HOME%\bin目录下,然后执行java -jar fmw_12.1.3.0.0_wls.jar就能安装了.
CCCK
CCCK
有效
Yanho
Yanho
亲测可行
0
w
wanglj2015

引用来自“stackport”的评论

把fmw_12.1.3.0.0_wls.jar放到%JAVA_HOME%\bin目录下,然后执行java -jar fmw_12.1.3.0.0_wls.jar就能安装了.
方法有效
0
f
f403078390

不行啊   大侠们还有没有其它的办法   

返回顶部
顶部