mmseg4j-1.9.1与Lucene-4.10.1异常

jhnm 发布于 2014/11/15 17:04
阅读 1K+
收藏 0

我用的Lucene4.10.1和mmseg4j的1.9.1在部署solr的时候,core没有加载进来,我add core之后就报了这个错

ERROR servlet.SolrDispatchFilter - null:java.lang.VerifyError: class com.chenlb.mmseg4j.solr.MMSegTokenizerFactory overrides final method create.(Ljava/io/Reader;)Lorg/apache/lucene/analysis/Tokenizer;

我修改TokenizerFactory类的public /*final*/ Tokenizer create(Reader input)之后,启动solr服务时初始化MMSegTokenizerFactory出错,是dicPath="dic"这个需要修改为data吗,还是其他问题?

我想问1.9.1的mmseg4j最多能用哪个版本的Lucene。

mmseg4j能解析【金属平垫\\Φ37 31×1.5 08#】这类复杂的语句吗?


加载中
0
buglife
buglife
这是要实现全文检索吗?有个elasticsearch蛮好用的,可以试试。另外如果是Solr的话,启动报错想寻求帮助,那么你应该将完整的错误日志贴出来。你这样子的描述   理解起来有点难
0
j
jhnm
来不及换elasticsearch了,这个问题能回答吗http://www.oschina.net/question/2272552_194153
0
lucenecn
lucenecn

用这个版本

https://github.com/solrcn/mmseg4j-solr

返回顶部
顶部