iBoxDB 什么时候支持asp.net core的?

AA海纳百川 发布于 2016/09/26 09:59
阅读 427
收藏 0

@iBoxDB 你好,想跟你请教个问题:什么时候支持asp.net core的?

加载中
0
iBoxDB
iBoxDB

你是指 #ftserver# 这个项目还是指 #iBoxDB# 这个项目, #iBoxDB#是可以运行在 core下的 https://www.nuget.org/packages/iBoxDB/

#ftserver# 因为当前一些免费.net测试主机还不支持core,为了更好支持免费主机,暂时不会升级到 core, 但自己修改一下很容易,引擎代码是支持core的,主要是界面代码是aspx. 

0
AA海纳百川
AA海纳百川
Errors in E:\Code\������������Ʒ���ƽ̨\YBBHLK.WuLian V1\src\ƽ̨\YBBHLK\YBBHLK.xproj
    Package iBoxDB 2.9.1 is not compatible with netcoreapp1.0 (.NETCoreApp,Version=v1.0). Package iBoxDB 2.9.1 supports:
      - dnxcore50 (DNXCore,Version=v5.0)
      - net (.NETFramework,Version=v0.0)
      - net20 (.NETFramework,Version=v2.0)
      - net45 (.NETFramework,Version=v4.5)
    One or more packages are incompatible with .NETCoreApp,Version=v1.0.
0
AA海纳百川
AA海纳百川
不能支持,
0
iBoxDB
iBoxDB
asp.net core 应该可以使用 dnxcore50 (DNXCore,Version=v5.0)这个环境,试一下,不行我再下载新版本VS测试下。
0
iBoxDB
iBoxDB

查了一下文档, MS名字换得真快,这几年它换了很多个名字了。

  • dnxcore50: DNX SDK running on CoreCLR/CoreFx (deprecated, use netcoreapp1.0 instead).

0
AA海纳百川
AA海纳百川
是的,不过我把dnxcore50加到project.json里之后也可以引用了。
0
iBoxDB
iBoxDB
MS把同样的东西不断换名字让第三方不能很好兼容。
0
iBoxDB
iBoxDB
  Nancy 是一个更简单实用的Web开发方案。
0
iBoxDB
iBoxDB
我在 VS2015 Update3上创建的 asp.net core 使用的是 dnxcore50,  你是使用什么工具创建asp.net core的?
0
AA海纳百川
AA海纳百川
同样版本,只不过默认是dotnet5.6 和portable-net45+win8
返回顶部
顶部