Eclipse新建项目报错

wolfbigbig 发布于 2016/03/01 19:09
阅读 297
收藏 0
使用Eclipse新建项目时,minSdkVersion="8",targetSdkVersion="19".
自动生成appcompat v7.但是依赖包报错,项目红色感叹号。更加不可理解的是提示
D:\DailyStudy\Android\NDKProject\appcompat_v7\res\values-v21\styles_base_text.xml:30: error: Error retrieving parent for item: No resource found that matches the given name 'android:TextAppearance.Material.Headline'.。

因此无法生成R文件,我明明选择19.为何有values-v21的问题呐?

 我现在的Android SDK Build-tools为23.0.2;Android SDK Tools为24.4.1;Android SDK Platform-tools为23.1;ADT版本为:23.0.6。

加载中
0
hgfgoodcreate
hgfgoodcreate
说的是找不到这个类:`android:TextAppearance.Material.Headline',是不是缺少相应的依赖包?
0
MockMan
MockMan
更新下你的android sdk
wolfbigbig
wolfbigbig
回复 @我叫头条 : 我现在的Android SDK Build-tools为23.0.2;Android SDK Tools为24.4.1;Android SDK Platform-tools为23.1;ADT版本为:23.0.6。应该都是最新的。
MockMan
MockMan
和adt插件
返回顶部
顶部