你好,关于phalcon入门的问题

bestia 发布于 2014/10/04 15:44
阅读 3K+
收藏 1

@吾爱 你好,想跟你请教个问题:

我是phalcon的初学者,按照官方网站上的说明配置了nginx和php5-fpm,然后就是下载网上的demo,但是无论是任何一个实例,都是首页可以正常打开,然后里面任何一个链接,比如说 /sign,contact/index 这样的连接都是出现404 file not find,这样的错误,请问你遇到或了解这样的错误么?

配置我是严格按照官方网站上的说明来的

加载中
0
记住一座城
记住一座城
我配置nginx也没有成功,换成apache就可以了。
b
bestia
你好,我按照你的方法,重新用apache2可以了,我想这应该是官方教程在nginx上的重写有问题。。。。 当然我还是希望能在nginx上解决问题,我看看能否解决,起码有了方向
0
CheneyWong
CheneyWong

1. linux下的看一下目录权限. 全部刷成 755.

2. 把链接大全看看, /sign/index.php 之类的.

0
b
bestia

引用来自“重庆崽儿”的评论

我配置nginx也没有成功,换成apache就可以了。

不过我用另一个虚拟机运行nginx(就是之前屡屡有错误的)居然又成功了,我到现在都不确定我干什么了,只是把base_url 修改为/了

不管怎样,能成功运行,真是可喜可贺,先给你加一分。

记住一座城
记住一座城
可能跟pathinfo有关,按照官方文档操作没成功过,你的配置文件看一下。
0
b
bestia

配置文件001,位于 /etc/nginx/sites-enabled

server {
	listen 80;
        server_name localhost;
        set $root_path '/home/bestia/www/phalcon-demo/public';
        root $root_path;
        index index.php index.html index.htm;
        
        access_log /home/bestia/www/log/access.log;
        error_log  /home/bestia/www/log/error.log error;

        try_files $uri $uri/ @rewrite;

        location @rewrite {
            rewrite ^/(.*)$ /index.php?_url=/$1;
        }

	location ~ \.php$ {
		fastcgi_split_path_info ^(.+\.php)(/.+)$;
		fastcgi_pass unix:/var/run/php5-fpm.sock;
		fastcgi_index /index.php;
		include fastcgi_params;
                fastcgi_param PATH_INFO $fastcgi_path_info;
                fastcgi_param PATH_TRANSLATED $document_root$fastcgi_path_info;
                fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
	}

        location ~* ^/(css|img|js|flv|swf|download)/(.+)$ {
                root $root_path;
        }

	location ~ /\.ht {
		deny all;
	}        
}




0
吾爱
吾爱

直接访问 /index.php?_url=/sign

试试?

返回顶部
顶部