lukeall无法打开lucene4.1的索引文件

tianpeng91 发布于 2013/02/20 16:46
阅读 2K+
收藏 0
最近在学习lucene4.1,发现一个问题,lukeall无法打开lucene4.1的索引文件,这是为什么呢?一直报no valid directory。。。坑爹啊,我记得3.6好像是可以的,是这样的吗?还是我操作有误呢
加载中
0
红薯
红薯
因为 luke 很久没更新,不支持最新版本
tianpeng91
tianpeng91
回复 @红薯 : 去啊,我之前用的3.5发现不行,今天发现有4.0了,心想可以用了,擦,,,一用结果支持到lucene4.0,4.1的还是不认识,坑爹啊,如何是好呢?
红薯
红薯
回复 @张浩春 : same to you
tianpeng91
tianpeng91
回复 @红薯 : 这个。。。好吧,你快找,找到了记得告诉我下啊,嘿嘿
红薯
红薯
回复 @张浩春 : 我也在找呢
tianpeng91
tianpeng91
。。。那你有没有好的查看索引文件的工具推荐下啊,红薯
0
懒洋洋地减肥
懒洋洋地减肥
看看源码改造一下,发上来给大家用吧
懒洋洋地减肥
懒洋洋地减肥
@张浩春 等我有空,我弄下,最近在忙着公司的搜索系统更新
tianpeng91
tianpeng91
。。。。木那本事啊
0
无我更忧愁
无我更忧愁
有下载,支持最新。https://java.net/projects/opengrok/downloads
江梓龙
江梓龙
十分感谢
0
GreenArrow
GreenArrow

引用来自“无我更忧愁”的答案

有下载,支持最新。https://java.net/projects/opengrok/downloads
果真,谢谢啦!!!!
0
银古
银古
解决大问题了
0
milin
milin
这里面有最新版本的: https://github.com/tarzanek/luke
返回顶部
顶部