在android上如何使用 ActiveRecordPlugin

零悦 发布于 2013/04/23 21:13
阅读 443
收藏 1

@JFinal 你好,想跟你请教个问题:

请问有在android上如何使用 ActiveRecordPlugin


很喜欢ActiveRecordPlugin,刚开始做android开发,想在android上使用ActiveRecordPlugin,却不知如何下手。

在网上找了很久也没找到例子。


加载中
0
JFinal
JFinal
使用这个问答中提供的方法在非Web环境下启动ActiveRecordPlugin: http://www.oschina.net/question/173052_59956 。通常在android下会使用sqlite数据库,所以还需要注意在创建数据源时指定sqlite驱动,以及为ActiveRecordPlugin指定 Sqlite3Dialect 方言。
0
零悦
零悦

引用来自“JFinal”的答案

使用这个问答中提供的方法在非Web环境下启动ActiveRecordPlugin: http://www.oschina.net/question/173052_59956 。通常在android下会使用sqlite数据库,所以还需要注意在创建数据源时指定sqlite驱动,以及为ActiveRecordPlugin指定 Sqlite3Dialect 方言。
报jFinal和JFinal提供的SQLite驱动加到项目上,按在非Web环境下启动arp,在运行的时候,eclipse提示以下错误。按了确定之后,整个eclipse都关闭了。
Unable to execute dex: GC overhead limit exceeded
GC overhead limit exceeded
我想,是不是SQLite驱动的问题,既然Android能操作SQLite,那应该有SQLite驱动,不用自己再添加。可是不知在那找那驱动出来
0
JFinal
JFinal

引用来自“零悦”的答案

引用来自“JFinal”的答案

使用这个问答中提供的方法在非Web环境下启动ActiveRecordPlugin: http://www.oschina.net/question/173052_59956 。通常在android下会使用sqlite数据库,所以还需要注意在创建数据源时指定sqlite驱动,以及为ActiveRecordPlugin指定 Sqlite3Dialect 方言。
报jFinal和JFinal提供的SQLite驱动加到项目上,按在非Web环境下启动arp,在运行的时候,eclipse提示以下错误。按了确定之后,整个eclipse都关闭了。
Unable to execute dex: GC overhead limit exceeded
GC overhead limit exceeded
我想,是不是SQLite驱动的问题,既然Android能操作SQLite,那应该有SQLite驱动,不用自己再添加。可是不知在那找那驱动出来
下载这个zip包,JFinal所有相关包在全都在,里面配有说明文件:  https://jfinal.googlecode.com/files/JFinal-lib-1.3.zip
JFinal
JFinal
先用纯jdbc测试测试数据操作,然后再将jdbc得到的DataSource传给ActiveRecrodPlugin来用,Android下可能不支持C3p0Plugin
零悦
零悦
不行,一运行就报上面那错误
返回顶部
顶部