spring从哪个版本开始支持mongodb?

Sunny 发布于 2012/02/15 10:40
阅读 2K+
收藏 0
现在的项目是基于spring2.5.6版本,但从网上的得到的实例支持MongoDB均为spring3.x版本,所以特别想知道 spring2.5.6是否支持,谢谢!
加载中
0
红薯
红薯
Spring Data 这个项目才支持 MongoDB 吧
Sunny
Sunny
谢谢,红薯大哥! 对的,是Spring Data支持MongoDB,问题在于Spring Data对应的spring版本不是很清楚
0
好大一条鱼
好大一条鱼
打个电话到VMware公司问 
Sunny
Sunny
呵呵,办法挺好的。
0
winnie_tour
winnie_tour
我项目中用的是spring 3.0.5.RELEASE,mongodb在spring中集成正如红薯所说,需要spring data的支持,spring-data-commons-core 1.1.0.M1,spring-data-document-core 1.0.0.M2,spring-data-mongodb 1.0.0.M2,mongo用的2.7.2
Sunny
Sunny
对的,我跑起来的demo是和你现在的jar包是一直的。关键是现在的项目是基于spring2.5.6,现行的目的是用mongoDB取代部分mysql的功能,进而逐渐推开
0
winnie_tour
winnie_tour
那你可以去看下spring的官网网站对spring data项目的描述,找到对应的版本,不过你也可以试试这几个包能不能在spring 2.5版本跑起来
0
羅立安的眼光
羅立安的眼光
我用的是spring 3.0.6,spring data 1.2.0.M2,mongo db 2.0.0
0
IEF
IEF
spring2 跑不起来
0
陈惟鲜
  1. ss
  2. 33
  3. 44
  4. 55
  5. 66
  6. 77
  7. 88
返回顶部
顶部