启动服务时初实化c3p0被卡死

chenghao 发布于 2013/05/02 09:28
阅读 11K+
收藏 0
2013-05-02 09:20:42,750:INFO : com.mchange.v2.log.MLog - MLog clients using log4j logging.
2013-05-02 09:20:42,812:INFO : com.mchange.v2.c3p0.C3P0Registry - Initializing c3p0-0.9.1.2 [built 21-May-2007 15:04:56; debug? true; trace: 10]
2013-05-02 09:20:43,359:INFO : com.mchange.v2.c3p0.impl.AbstractPoolBackedDataSource - Initializing c3p0 pool... com.mchange.v2.c3p0.ComboPooledDataSource [ acquireIncrement -> 5, acquireRetryAttempts -> 30, acquireRetryDelay -> 1000, autoCommitOnClose -> false, automaticTestTable -> null, breakAfterAcquireFailure -> false, checkoutTimeout -> 0, connectionCustomizerClassName -> null, connectionTesterClassName -> com.mchange.v2.c3p0.impl.DefaultConnectionTester, dataSourceName -> 1hge1458urf5lwd1g5ncck|10d78ec, debugUnreturnedConnectionStackTraces -> false, description -> null, driverClass -> com.mysql.jdbc.Driver, factoryClassLocation -> null, forceIgnoreUnresolvedTransactions -> false, identityToken -> 1hge1458urf5lwd1g5ncck|10d78ec, idleConnectionTestPeriod -> 1800, initialPoolSize -> 10, jdbcUrl -> jdbc:mysql://192.168.1.37:3306/damiwan?useUnicode=true&characterEncoding=UTF-8&zeroDateTimeBehavior=convertToNull&rewriteBatchedStatements=true, maxAdministrativeTaskTime -> 0, maxConnectionAge -> 0, maxIdleTime -> 0, maxIdleTimeExcessConnections -> 0, maxPoolSize -> 60, maxStatements -> 0, maxStatementsPerConnection -> 0, minPoolSize -> 10, numHelperThreads -> 32, numThreadsAwaitingCheckoutDefaultUser -> 0, preferredTestQuery -> select 1 from dual, properties -> {user=******, password=******}, propertyCycle -> 0, testConnectionOnCheckin -> true, testConnectionOnCheckout -> false, unreturnedConnectionTimeout -> 0, usesTraditionalReflectiveProxies -> false ]


启动tomcat或是用junit运行时在这地方就被卡死了

加载中
2
wwwjjj
wwwjjj

一般来说 在连库过程中出问题才会卡住

检查验证下  连库的配置是否正确  再就是数据库链接数是否正常

Cavalier
Cavalier
不简简单单使这个问题。 确实出现过这种情况
0
chenghao
chenghao
现在发现问题了,  用的是mybatis, 在mapper.xml里面写错了造成的。
0
aldo
aldo

我也犯过这样错误:

现在发现问题了,  用的是mybatis, 在mapper.xml里面写错了造成的。

就是XXXmapper.xml文件某些地方写错啦。

haanya168
haanya168
你的是mybatis配置文件哪里错误的,给个提示
返回顶部
顶部