mediawiki安装CKEditor插件

along515 发布于 2014/09/09 12:48
阅读 4K+
收藏 1
公司以前用的lunix+mediawiki,本想扩展使用FCKeditor,后来发现FCKeditor已经不能使用,被CKeditor取代,在网上找了很久关于mediawiki下配置CKeditor的信息,信息量很少,不知有没有人配置成功,由于是新人,没弄过,如果有人配置成功,能不能将步骤和配置文件修改发出来,如果有需要注意的地方,也还麻烦提醒一下。谢谢。
加载中
0
胖的明显
胖的明显

刚好我这两天配置过。不我我是在win2008下,但是应该差不多你可以借鉴一下。

现在是升级到WYSIWYG-CKeditor-CKeditor_v4,下载解压会有如图文件

给整个WYSIWYG文件夹复制到mediawiki的extensions目录下。然后给mediawiki根目录下的LocalSettings.php添加以下行就可以了:

require_once("$IP/extensions/WikiEditor/WikiEditor.php");
require_once("$IP/extensions/WYSIWYG/WYSIWYG.php");
$wgGroupPermissions['*']['wysiwyg']=true;
$wgDefaultUserOptions['cke_show']='richeditor';
$wgDefaultUserOptions['riched_use_toggle']=true;
$wgDefaultUserOptions['riched_start_disabled']=false;
$wgDefaultUserOptions['riched_toggle_remember_state']=true;
$wgDefaultUserOptions['riched_use_popup']=false;
$wgFCKEditorExcludedNamespaces[]= NS_MEDIAWIKI;
$wgFCKEditorExcludedNamespaces[]= NS_TEMPLATE;
$wgAllowCopyUploads = true;
$wgAllowExternalImages = true;




0
韦不良
韦不良

linux下的 这几天刚才遇到 哈哈 

cp -r  WYSIWYG/    extensions/WYSIWYG/
vim LocalSettings.php
#add 
require_once "$IP/extensions/WYSIWYG/WYSIWYG.php";


http://www.linuxchina.net/?p=2881

返回顶部
顶部