echarts折线被遮挡

简简单单生活 发布于 2015/11/03 15:44
阅读 307
收藏 0

@莫铭 你好,想跟你请教个问题:

我使用echarts画折线图,现在我画的后面那条折线被遮挡了,请问怎么实现不被遮挡的效果勒。

加载中
0
莫铭
莫铭

echart默认会按照series顺序渲染折线,默认面积图是半透明效果的,由于你设置了自定义颜色,面积图变成不透明了,所以排在后面的面积图会覆盖掉排前面的折线图。

解决办法:改变series中折线图顺序,只需将被覆盖的折线图的数据放到面积图后面。

例子:

var option = {
    series:[{
       面积图
    },{
       被覆盖的折线图
    }]
}



目前没找到设置面积图透明的参数,要不然,设置一下面积图的透明度,也不会覆盖了。


o
onewarden
可以设置面积图是否透明,参考 https://github.com/ecomfe/echarts/issues/746
0
yak
yak
这个图看着真丑
简简单单生活
简简单单生活
呵呵,我自己也觉得有点,第一张是我要的效果,但是我还没实现,所以就这样了。
返回顶部
顶部