qt creator 编译版本太高

Stark_ZC 发布于 2014/11/01 09:22
阅读 709
收藏 0

qt creator 在编译到时候,出现错误,提示版本太高:

CMake Error at /usr/share/cmake-2.8/Modules/FindQt4.cmake:1193 (MESSAGE):

Found unsuitable Qt version "5.3.2" from

/home/stark/Qt5.3.2/5.3/gcc/bin/qmake, this code requires Qt 4.x

Call Stack (most recent call first):

ros_tutorials-hydro-devel/turtlesim/CMakeLists.txt:6 (find_package)

这里值得版本太高,是指编译器还是整个qt creator,这个时候是不是用到了cmake?

加载中
0
公孙二狗
公孙二狗

requires Qt 4.x

指的是QtSDK

0
Stark_ZC
Stark_ZC

引用来自“jorneyr”的评论

requires Qt 4.x

指的是QtSDK

那我是不是要自己下个版本4.x的sdk,这样就可以了吗?我遇到过这种情况,电脑在第二天打开后,qt的这个错误就没有了,这个是随机的吗?
0
公孙二狗
公孙二狗

引用来自“jorneyr”的评论

requires Qt 4.x

指的是QtSDK

引用来自“Stark_ZC”的评论

那我是不是要自己下个版本4.x的sdk,这样就可以了吗?我遇到过这种情况,电脑在第二天打开后,qt的这个错误就没有了,这个是随机的吗?

嗯,下载Qt4的SDK

返回顶部
顶部