CHECK_NRPE: Error - Could not complete SSL handshake.

空白格1 发布于 2014/08/10 12:01
阅读 3K+
收藏 0

在nagios服务器端执行以下命令报错:

[root@nagios libexec]# ./check_nrpe -H localhost

NRPE v2.12
[root @nagios libexec]# ./check_nrpe -H 192.168.1.18
CHECK_NRPE: Error - Could not complete SSL handshake.
[root @nagios libexec]# ./check_nrpe -H 192.168.1.52
CHECK_NRPE: Socket timeout after 10 seconds.
[root @nagios libexec]# ./check_nrpe -H 127.0.0.1

NRPE v2.12

其中192.168.1.18是本地ip,192.168.1.52是被监控端ip,被监控端执行命令结果如下:

# ./check_nrpe -H 192.168.1.52
NRPE v2.12

客户端nrpe.cfg配置为:

# ALLOWED HOST ADDRESSES
# This is an optional comma-delimited list of IP address or hostnames
# that are allowed to talk to the NRPE daemon.
#
# Note: The daemon only does rudimentary checking of the client's IP
# address.  I would highly recommend adding entries in your /etc/hosts.allow
# file to allow only the specified host to connect to the port
# you are running this daemon on.
#
# NOTE: This option is ignored if NRPE is running under either inetd or xinetd


allowed_hosts=192.168.1.18,127.0.0.1


# SERVER ADDRESS
# Address that nrpe should bind to in case there are more than one interface
# and you do not want nrpe to bind on all interfaces.
# NOTE: This option is ignored if NRPE is running under either inetd or xinetd


#server_address=192.168.1.52


请问是什么错误?另外nagiso nrpe自身有没有日志文件?谢谢!

加载中
0
valiantjiang
valiantjiang

需要在被监控机上添加nagios主机的访问权限:

vim /usr/local/nagios/etc/nrpe.cf

allowed_hosts=127.0.0.1,172.16.16.150



vim /etc/xinetd.d/nrpe 

only_from= 127.0.0.1 172.16.16.150



返回顶部
顶部