android6.0.1源码编译报错如下,求教~~~

zrcker 发布于 2015/12/29 15:33
阅读 5K+
收藏 0

android源码编译报错 版本 6.0.1  环境mac os x

2 warnings generated.

[ 32% 8750/26638] Ensure Jack server is installed and started

FAILED: /bin/bash -c "(true) && (prebuilts/sdk/tools/jack-admin install-server prebuilts/sdk/tools/jack-launcher.jar prebuilts/sdk/tools/jack-server-4.1.ALPHA.jar  2>&1 || (exit 0)) && (JACK_SERVER_VM_ARGUMENTS=\"-Dfile.encoding=UTF-8 -XX:+TieredCompilation\" prebuilts/sdk/tools/jack-admin start-server 2>&1 || exit 0) && (prebuilts/sdk/tools/jack-admin update server prebuilts/sdk/tools/jack-server-4.1.ALPHA.jar 4.1.ALPHA 2>&1 || exit 0) && (prebuilts/sdk/tools/jack-admin update jack prebuilts/sdk/tools/jacks/jack--1.1.PRE_ALPHA.jar -1.1.PRE_ALPHA || exit 47; prebuilts/sdk/tools/jack-admin update jack prebuilts/sdk/tools/jacks/jack--1.2.PRE_ALPHA.jar -1.2.PRE_ALPHA || exit 47; prebuilts/sdk/tools/jack-admin update jack prebuilts/sdk/tools/jacks/jack--1.3.PRE_ALPHA.jar -1.3.PRE_ALPHA || exit 47; prebuilts/sdk/tools/jack-admin update jack prebuilts/sdk/tools/jacks/jack-2.26.RELEASE.jar 2.26.RELEASE || exit 47; prebuilts/sdk/tools/jack-admin update jack prebuilts/sdk/tools/jacks/jack-3.7.ALPHA.jar 3.7.ALPHA || exit 47; prebuilts/sdk/tools/jack-admin update jack prebuilts/sdk/tools/jacks/jack-3.8.ALPHA.jar 3.8.ALPHA || exit 47)"

Writing client settings in /Users/zrck/.jack-settings

Unsupported curl, please use a curl not based on SecureTransport

Launching Jack server java -Djava.io.tmpdir=/var/folders/6r/72rm98ss6h55ftgqht_xkb_m0000gn/T/ -Dfile.encoding=UTF-8 -XX:+TieredCompilation -cp /Users/zrck/.jack-server/launcher.jar com.android.jack.launcher.ServerLauncher

prebuilts/sdk/tools/jack-admin: line 248: /Users/zrck/.jack-server/logs/outputs.txt: No such file or directory

Jack server failed to (re)start, see Jack server log

Unsupported curl, please use a curl not based on SecureTransport

Unsupported curl, please use a curl not based on SecureTransport

[ 32% 8750/26638] target thumb C++: li...nal/icu/icu4c/source/i18n/plurrule.cpp

ninja: build stopped: subcommand failed.

make: *** [ninja_wrapper] Error 1

#### make failed to build some targets (48:47 (mm:ss)) ####

加载中
0
loften
loften
请问你解决了吗?是如何解决的
zrcker
zrcker
你好,这个问题我在https://code.google.com上提问过,没得到反馈,我删掉aosp,又重新rebuild,莫名其妙的通过了。。。。
返回顶部
顶部