android 入门问题:An SDK Target must be specified

Dianzi 发布于 2011/10/10 21:06
阅读 2K+
收藏 0

请教下高手,在设置new android project 时,已经依次

Project name(在计算机中存储工程的目录名): HelloWorld

Package name(包名,请参考Java相关的概念): com.china.hello

Activity name(UI界面窗口的类名,从Activity继承而来): HelloChina

Application name(应用的标题名字): test Android

但最上面出现了一个错误“ An SDK Target must be specified.”,敢问这怎么解决,补充下,我的Eclispe 和SDK都是最新版本,不知道是不是这个原因,设置会有所不同。

以下是问题补充:

@Dianzi:我的系统是win7,没看到Path ,这怎么办???? (2011/10/12 21:47)
@Dianzi:好像系统变量——>新建——>就出现了变量名和变量值,这是什么意思???求高手帮忙解决。。。。。 (2011/10/12 21:58)
加载中
0
鉴客
鉴客
创建一个虚拟机: android create avd --name <avdname> -- target 2
注意target选项根据自己的环境而定,可以用 android --target查看
0
无鸯
无鸯
我是在window操作系统上安装的
右键点击"我的电脑"-"属性"-"高级"-"环境变量"。
在"系统变量"那找到"Path",双击打开(注:如果没有Path这一项,则新建一项)。打开后,在"变量值"的最前面写上C:\Program Files\Java\jdk1.6.0_11\bin; (改成jdk实际安装的目录),确定关闭窗口。

右键点击"我的电脑","属性"|"高级"|"环境变量",在系统变量的path变量前加上 D:\android_sdk\tools; 新版的SDK还需要手动下载Platform,运行D:\android_sdk下SDK Setup.exe。如果它提示https不可用,则必须到settings里把"Force https...http:"这一项勾上。然后选择左边"Avaliable Packages",再选择一个SDK Platform,如"SDK Platform Android 2.1,API 7,revision 1",安装。
返回顶部
顶部