重装电脑之后移植回来的代码运行不了了!!!

sswie 发布于 2012/04/12 13:50
阅读 753
收藏 0

原本之前的系统上是没有任何问题的
但是重装系统 重新搭建了ide sql之后,就一直用不了了!
因为后天就要比赛了
所以请求大家一定要帮帮我啊!!!

错误提示如下 

2011-4-12 13:37:33 org.apache.catalina.startup.HostConfig deployDescriptor

信息: Deploying configuration descriptor lostcenter.xml from C:\springsource\vfabric-tc-server-developer-2.5.0.RELEASE\spring-insight-instance\conf\Catalina\localhost

2011-4-12 13:37:33 org.apache.catalina.startup.SetContextPropertiesRule begin

警告: [SetContextPropertiesRule]{Context} Setting property 'source' to 'org.eclipse.jst.jee.server:lostcenter' did not find a matching property.

[TomcatWeavingInsightClassLoader@1f32e] warning ignoring duplicate definition: jar:file:/C:/springsource/vfabric-tc-server-developer-2.5.0.RELEASE/spring-insight-instance/insight/collection-plugins/insight-collection-1.5.0.RELEASE.jar!/META-INF/aop.xml

[TomcatWeavingInsightClassLoader@1f32e] warning ignoring duplicate definition: jar:file:/C:/springsource/vfabric-tc-server-developer-2.5.0.RELEASE/spring-insight-instance/insight/collection-plugins/insight-plugin-jdbc-1.5.0.RELEASE.jar!/META-INF/aop.xml

[TomcatWeavingInsightClassLoader@1f32e] warning ignoring duplicate definition: jar:file:/C:/springsource/vfabric-tc-server-developer-2.5.0.RELEASE/spring-insight-instance/insight/collection-plugins/insight-collection-1.5.0.RELEASE.jar!/META-INF/aop-ajc.xml

[TomcatWeavingInsightClassLoader@1f32e] warning ignoring duplicate definition: jar:file:/C:/springsource/vfabric-tc-server-developer-2.5.0.RELEASE/spring-insight-instance/insight/collection-plugins/insight-plugin-tomcat-1.5.0.RELEASE.jar!/META-INF/aop-ajc.xml

[TomcatWeavingInsightClassLoader@1f32e] warning ignoring duplicate definition: jar:file:/C:/springsource/vfabric-tc-server-developer-2.5.0.RELEASE/spring-insight-instance/insight/collection-plugins/insight-plugin-jdbc-1.5.0.RELEASE.jar!/META-INF/aop-ajc.xml

ASPECTJ: aspectj.overweaving=true: overweaving switched ON

2011-4-12 13:37:33 org.apache.catalina.startup.HostConfig deployDescriptor

严重: Error deploying configuration descriptor lostcenter.xml

java.lang.UnsupportedClassVersionError: cn/edu/gxu/xingjian/cl/control/UserClServlet : Unsupported major.minor version 51.0 (unable to load class cn.edu.gxu.xingjian.cl.control.UserClServlet)

at org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebappClassLoader.java:2822)

at org.apache.catalina.loader.WebappClassLoader.findClass(WebappClassLoader.java:1148)

at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1643)

at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1521)

at org.apache.catalina.startup.WebAnnotationSet.loadApplicationServletAnnotations(WebAnnotationSet.java:108)

at org.apache.catalina.startup.WebAnnotationSet.loadApplicationAnnotations(WebAnnotationSet.java:58)

at org.apache.catalina.startup.ContextConfig.applicationAnnotationsConfig(ContextConfig.java:353)

at org.apache.catalina.startup.ContextConfig.configureStart(ContextConfig.java:885)

at org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:317)

at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)

at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:89)

at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5081)

at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:145)

at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:812)

at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:787)

at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:607)

at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:633)

at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:558)

at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:468)

at org.apache.catalina.startup.HostConfig.check(HostConfig.java:1363)

at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:294)

at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)

at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:89)

at org.apache.catalina.core.ContainerBase.backgroundProcess(ContainerBase.java:1233)

at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1391)

at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1401)

at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.run(ContainerBase.java:1380)

at java.lang.Thread.run(Thread.java:675)

加载中
0
Ken
Ken
试下将这个project清理一次,重新编译
Ken
Ken
Project -> Clean
s
sswie
可以麻烦您告诉我一下,怎么清理吗?
0
红薯
红薯
你编译java文件的编译器版本跟运行的那个版本不兼容,两个版本分别是什么?
s
sswie
现在是1.7,myeclipse里面的是1.6.是不是我要把1.7的卸载然后装1.6的?myeclipse里面可选的只有1.6 ,1.5 ,1.4 ,1.3........
0
s
sswie
Clean一下
返回顶部
顶部