django 安装报错,求助求助

zhaoxvip 发布于 2014/09/10 23:18
阅读 7K+
收藏 0
SyntaxError: ('invalid syntax', ('/usr/local/lib64/python2.6/site-packages/Django-1.7-py2.6.egg/django/test/signals.py', 103, 41, "    if kwargs['setting'] in {'LANGUAGES', 'LANGUAGE_CODE', 'LOCALE_PATHS'}:\n"))


SyntaxError: ('invalid syntax', ('/usr/local/lib64/python2.6/site-packages/Django-1.7-py2.6.egg/django/core/management/__init__.py', 68, 39, "    commands = {name: 'django.core' for name in find_commands(__path__[0])}\n"))


SyntaxError: ('invalid syntax', ('/usr/local/lib64/python2.6/site-packages/Django-1.7-py2.6.egg/django/core/management/commands/makemessages.py', 351, 44, "        dir_suffixes = {'%s*' % path_sep for path_sep in {'/', os.sep}}\n"))


SyntaxError: ('invalid syntax', ('/usr/local/lib64/python2.6/site-packages/Django-1.7-py2.6.egg/django/forms/utils.py', 57, 34, '        return {f: e.as_data() for f, e in self.items()}\n'))


SyntaxError: ('invalid syntax', ('/usr/local/lib64/python2.6/site-packages/Django-1.7-py2.6.egg/django/utils/lru_cache.py', 28, 34, '                 fasttypes = {int, str, frozenset, type(None)},\n'))


SyntaxError: ('invalid syntax', ('/usr/local/lib64/python2.6/site-packages/Django-1.7-py2.6.egg/django/contrib/formtools/tests/wizard/wizardtests/tests.py', 128, 40, "        with open(THIS_FILE, 'rb') as f, temp_storage.open(UPLOADED_FILE_NAME) as f2:\n"))


SyntaxError: ('invalid syntax', ('/usr/local/lib64/python2.6/site-packages/Django-1.7-py2.6.egg/django/contrib/formtools/tests/wizard/namedwizardtests/tests.py', 160, 40, "        with open(THIS_FILE, 'rb') as f, temp_storage.open(UPLOADED_FILE_NAME) as f2:\n"))


SyntaxError: ('invalid syntax', ('/usr/local/lib64/python2.6/site-packages/Django-1.7-py2.6.egg/django/contrib/auth/tests/test_forms.py', 123, 42, "        with self.settings(USE_I18N=True), translation.override('pt-br', deactivate=True):\n"))


SyntaxError: ('invalid syntax', ('/usr/local/lib64/python2.6/site-packages/Django-1.7-py2.6.egg/django/contrib/humanize/tests.py', 95, 40, "        with translation.override('ja'), self.settings(USE_L10N=True):\n"))


SyntaxError: ('invalid syntax', ('/usr/local/lib64/python2.6/site-packages/Django-1.7-py2.6.egg/django/contrib/gis/db/backends/postgis/operations.py', 79, 34, "    valid_aggregates = {'Collect', 'Extent', 'Extent3D', 'MakeLine', 'Union'}\n"))


SyntaxError: ('invalid syntax', ('/usr/local/lib64/python2.6/site-packages/Django-1.7-py2.6.egg/django/contrib/gis/db/backends/oracle/operations.py', 86, 32, "    valid_aggregates = {'Union', 'Extent'}\n"))


SyntaxError: ('invalid syntax', ('/usr/local/lib64/python2.6/site-packages/Django-1.7-py2.6.egg/django/contrib/gis/db/backends/spatialite/operations.py', 68, 33, "    valid_aggregates = {'Extent', 'Union'}\n"))


SyntaxError: ('invalid syntax', ('/usr/local/lib64/python2.6/site-packages/Django-1.7-py2.6.egg/django/contrib/gis/db/models/constants.py', 4, 17, "    'bbcontains', 'bboverlaps', 'contained', 'contains',\n"))


SyntaxError: ('invalid syntax', ('/usr/local/lib64/python2.6/site-packages/Django-1.7-py2.6.egg/django/db/utils.py', 190, 44, '    TEST_SETTING_RENAMES_REVERSE = {v: k for k, v in TEST_SETTING_RENAMES.items()}\n'))


SyntaxError: ('invalid syntax', ('/usr/local/lib64/python2.6/site-packages/Django-1.7-py2.6.egg/django/db/backends/mysql/schema.py', 39, 61, "        return field.db_type(self.connection) in {'longtext', 'longblob'}\n"))


SyntaxError: ('invalid syntax', ('/usr/local/lib64/python2.6/site-packages/Django-1.7-py2.6.egg/django/db/models/fields/__init__.py', 639, 21, "            'iexact', 'contains', 'icontains',\n"))


SyntaxError: ('invalid syntax', ('/usr/local/lib64/python2.6/site-packages/Django-1.7-py2.6.egg/django/template/loader_tags.py', 145, 19, '                for name, var in six.iteritems(self.extra_context)\n'))


Django 1.7 is already the active version in easy-install.pth
Installing django-admin.py script to /usr/local/bin
Installing django-admin script to /usr/local/bin


Installed /usr/local/lib64/python2.6/site-packages/Django-1.7-py2.6.egg
Processing dependencies for Django==1.7
Finished processing dependencies for Django==1.7
加载中
1
明天以后
明天以后
Install Python Being a Python Web framework, Django requires Python. It works with Python 2.7, 3.2, 3.3, or 3.4. All these versions of Python include a lightweight database called SQLiteso you won’t need to set up a database just yet.
0
秀小川
秀小川
你的Python是哪个版本。如果是3.X换成2.7.X试试!
0
me坤子
me坤子
2.6就装1.6呗
0
fkkeee
fkkeee
1.7不支持Python2.6了。
0
zhaoxvip
zhaoxvip
非常感谢,在windows上用2.7装的1.7,在linux上习惯性的去装了。装1.4.5解决问题。
0
山下狮子
山下狮子
1.7好像只支持2.7  3.X.
返回顶部
顶部