linux下安装mysql5.7.15 报错,求解

咖啡加糖 发布于 2016/09/19 11:22
阅读 769
收藏 0

进入安装目录后执行  安装命令:

    rpm -ivh /usr/mysql/mysql5.7.15.rpm  


报如下错误:

error: Failed dependencies:
        mysql-community-client >= 5.7.9 is needed by mysql-community-server-5.7.15-1.sles12.x86_64
        mysql-community-common = 5.7.15-1.sles12 is needed by mysql-community-server-5.7.15-1.sles12.x86_64



我用使用查看命令,也没发现安装5.7.9这个版本  ???rpm -qa | grep -i mysql  


怎么回事????




加载中
0
快乐的一只小青蛙
快乐的一只小青蛙
mysql不止一个rpm文件,放在一个文件 然后rpm -i *.rpm就好
咖啡加糖
咖啡加糖
恩 就是这个原因
0
inuxor
inuxor
这就很奇怪了,suse里面需要自己去下载rpm?
0
lee123lee
lee123lee
哥哥,你的mysql-server没安装
咖啡加糖
咖啡加糖
server安装了,是common 和 lib 没安装 ,要先安装这两个
0
喂码呢
喂码呢
一直都是自己编译安装的
0
雨翔河
雨翔河
很明显没安装mysql-server
0
独孤青冥
独孤青冥
组件不全啊。。。MySQL可不止一个安装文件。。。
返回顶部
顶部