mac vim安装Bundle出错。。。。

Java_Coder 发布于 2015/10/23 15:55
阅读 1K+
收藏 0

Mac环境:::

在~/.vimrc配置:

et nocompatible              " be iMproved
filetype off                  " required!


set rtp+=~/.vim/bundle/vundle/
call vundle##rc()


Bundle 'scrooloose/nerdtree'  "文件浏览
Bundle 'majutsushi/tagbar'    "代码符号
Bundle 'wesleyche/SrcExpl'    "类似sourceInsight的代码预览窗口
filetype plugin indent on     " required!
"vundle设置完毕


syntax on
let g:tagbar_ctags_bin='/usr/local/bin/ctags'
let g:tagbar_left = 1
nnoremap <F3> :TagbarToggle<CR>
let NERDTreeWinPos='right'
nnoremap <F2> :NERDTreeToggle<CR>
nmap <F4> :SrcExplToggle<CR>
let g:Srcexpl_winHeight = 8
" // Set 100 ms for refreshing the Source Explorer
let g:SrcExpl_refreshTime = 100

" // Set "Enter" key to jump into the exact definition context
" // Set "Space" key for back from the definition context
let g:SrcExpl_gobackKey = "<SPACE>"


let g:SrcExpl_pluginList = [
         \ "__Tag_List__",
                 \ "_NERD_tree_"
                     \ ]




set tags=tags;/  "搜索上一级建立的tag

nmap <C-H> <C-W>h "control+h进入左边的窗口
nmap <C-J> <C-W>j  "control+j进入下边的窗口
nmap <C-K> <C-W>k "control+k进入上边的窗口
nmap <C-L> <C-W>l  "control+l进入右边的窗口


已经用git安装了bundle,但是用vim的时候还是报了不识别bundle函数的错误。。。。   怎么解决。。

tianduoduodeMacBook-Pro:~ tianduoduo$ vim
Error detected while processing /Users/tianduoduo/.vimrc:
line    5:
E117: Unknown function: vundle##rc
line    7:
E492: Not an editor command: Bundle 'scrooloose/nerdtree'  "文件浏览
line    8:
E492: Not an editor command: Bundle 'majutsushi/tagbar'    "代码符号
line    9:
E492: Not an editor command: Bundle 'wesleyche/SrcExpl'    "类似sourceInsight的代码预览窗口







加载中
0
htfy96
htfy96
call vundle#begin()
Java_Coder
Java_Coder
试了一下,还是不行。。。。
htfy96
htfy96
用这个替换 call vundle##rc()
返回顶部
顶部