Ubuntu Linux下Mplayer万能播放器的设置

范堡 发布于 2009/05/08 10:49
阅读 1K+
收藏 0

sudo apt-get install mplayer-fonts mplayer mplayer-skins mozilla-mplayer linux 下mplayer 中文字幕配置
修改 ~/.mplayer/config # Write your default config options here! # 视频输出以xv模式,启用视频加速
vo=xv # 字幕字体文件
font = /usr/share/fonts/zh_CN/TrueType/hei.ttf # 字幕编码 (使用TTF字体时使用) subcp = cp936 # 0 不自动缩放; 1 按电影高度缩放; 2 按宽度; 3 按对角线
subfont-autoscale = 2 # 字幕字体大小
subfont-text-scale = 4 # 设置OSD元素的自动绽放系数
subfont-osd-scale = 6 font=/home/simsun.ttf subcp=cp936 subfont-autoscale=1 #这是控制自动装载字幕的,2和0都是不自动
subfont-text-scale=7#字体大小
有时侯用命令行的没有字幕,可以试一试快捷键“v”,和 “b”
用命令行时字符集别用unicode,用gb2312或者cp936都行
gui模式出现modoul 11 error,不知道原因。重新编译中
下面这篇文章是参考:
让mplayer支持中文字幕的解决方案
apt-get install mplayer后,播放一些带中文字幕的电影老显示不了中文字,会出现诸如:“___Ants,_____”的玩意,看了不少文档,终于搞定,下面总结一番
A~命令行方式播放:
这是我的~/.mplayer/config # Write your default config options here! font=/usr/share/fonts/truetype/hiweed/simsun.ttf subcp=cp936 subfont-autoscale=2 subfont-text-scale=5 vo=xv 然后,命令行输入mplayer aaa.avi,(前提是同目录下有同名字幕文件)。就OK了。
B~至于窗口模式,我采用以下方法也解决:
1.rm -rf /usr/share/mplayer/font/* 2.rm -rf ~/.mplayer/font/* 上面两步让gmplayer找不到那些英文字体,呵呵,就让它乖乖地用我们指定的字体:
3.ln -s /YOUR/PATH/TO/CHINESEFONT.ttf subfont.ttf 4.修改~/.mplayer/gui.conf如下项目:
sub_auto_load = "yes" sub_unicode = "yes" sub_pos = "100" sub_overlap = "no" sub_cp = "cp936" font_factor = "0.750000" font_name = "/home/badants/.mplayer/subfont.ttf" font_encoding = "unicode" 然后,打开gmplayer,试试看,能不能成功。
(责任编辑:云子)

加载中
返回顶部
顶部