Firefox占用CPU、内存等资源过大的优化方案!

范堡 发布于 2011/03/22 13:37
阅读 11K+
收藏 2

转帖的,有兴趣的朋友试试看:

 

最近爱上用firefox,但是发现firefox占用内存大、CPU占用率高,并且有时打开网页有停顿等问题,在网上搜索了一下这个问题,是因为firefox的默认设置是标准的设置,没有进行优化。优化方案如下:

首先解决CPU占用率高,打开网页停顿的问题

很简单,在“工具”/“选项”/“内容”里,找到“启用Java“这一项,去掉前面的勾,然后确认,重启即可解决问题。简单的很。

然后呢,按上面的设置只可解决CPU占用率高的问题,但你打开任务管理器,会发现FIREFOX的内存占用率也很高,这样会使内存小的朋友抓襟见肘。这个也有解决办法。只因FIREFOX没有设置快速缓存和自动释放内存。下面开始:

当你在长时间使用Firefox时,它所占用的内存量也会随时间不断增加。
你可以考虑定期地重新启动Firefox,以让它维持在一个固定的内存占用量上。

为Firefox设置快速缓存

在默认情况下,Firefox只会使用系统内存而不会使用快速缓存,如果为其设置使用快速缓存,那么就可以减轻内存的负担。以下是具体操作步骤:

1、打开Firefox浏览器。

2、在地址栏中输入“about:config”。

3、在“过滤器”中输入“browser.cache.memory.enable”。

4、要先确保其值为“true”,如果不是的话,可以双击这个项目,之后它的值就会转变为“true”。

5、在浏览器中右键点击后选择“新建”>“整数”。

6、输入“browser.cache.memory.capacity”后点击“确定”。

7、接着,你需要在此输入一个值,而这个值的大小则取决于你计算机物理内存的大小。

8、如果你的内存大小为256MB,则输入“4096”;而如果你的内存大小为512MB的话,则输入“8192”。

9、注意:如果你的内存还是128MB甚至更低的话,那么建议购买内存升级,内存现在并不是很昂贵。

提示:如果你想要恢复默认设置的话,你可以将“browser.cache.memory.capacity”的值改为“-1”。

当Firefox最小化时释放内存

1、打开Firefox浏览器。

2、在地址栏中输入“about:config”。

3、在浏览器中右键点击,选择“新建”>“布尔”。

4、在弹出的窗口中输入“config.trim_on_minimize”,接着点击“确定”。

5、选中“true”,接着点击“确定”。

6、重新启动Firefox即可。

加载中
0
ddatsh
ddatsh

这两个真的不太靠谱

设 urlclassifier3.sqlite 只读是终极解决方案步骤里的一个

0
小编辑
小编辑

非常不靠谱,哪有启用Java啊,是启用JavaScript,而且一旦不启用JavaScript,很多网站上的操作都无法执行。

0
大大
大大

版主又没自己试过啊

0
JonasBollack
JonasBollack

最小化释放内存那个在windowsXP下面好用,但是windows7貌似就不行了

0
周立行

感觉firefox4真的好用呢

0
luxp
luxp

xp下我刚试验过 效果非常的好

0
ddatsh
ddatsh

xp下根本体会不到WIN7下华丽丽的效果

0
酒瓶不倒
酒瓶不倒
这个很不靠谱阿
返回顶部
顶部