13
回答
centos 安装php5.2脚本解析器
百度AI开发者大赛带你边学边开发,赢100万奖金,加群:418589053   
apache和mysql都装好了 php却是装的5.3 因为程序必须要zend optimizer 所以要换回5.2的 但是源里面都是5.3和5.4的 木有5.2的 这个咋办 求大家帮忙 要么给个5.2的源 要么教我一下5.2的包怎么编译的吧...
举报
胖胖
发帖于5年前 13回/1K+阅

以下是问题补充:

  • @胖胖 :各种依赖搞定 准备安装的时候 make ZEND_EXTRA_LIBS='-liconv' make: *** 没有指明目标并且找不到 makefile。 停止。 (5年前)
共有13个答案 最后回答: 5年前

引用来自“景上青”的答案

lnmp.org
我不要集成的 这个lnmp 下个包直接安装就好了 我现在别的都好了 只要php5.2版本的 不会编译

引用来自“JSON.org.cn”的答案

5.2 的源代码, 官网都有的. configure make, So Easy.
官网看了下 只有最低5.3

http://museum.php.net/php5/php-5.2.17.tar.gz

hash 补丁:https://github.com/laruence/laruence.github.com/tree/master/php-5.2-max-input-vars

引用来自“client”的答案

http://museum.php.net/php5/php-5.2.17.tar.gz

hash 补丁:https://github.com/laruence/laruence.github.com/tree/master/php-5.2-max-input-vars

各种依赖搞定 准备安装的时候

 make ZEND_EXTRA_LIBS='-liconv' 

 make: *** 没有指明目标并且找不到 makefile。 停止。

--- 共有 1 条评论 ---
client./configure --配置参数 先生成配置文件,然后再make && make install 5年前 回复
顶部