Linux系统中tomcat环境如何设置jvm参数

小张java 发布于 2014/06/04 10:38
阅读 5K+
收藏 1
如题,我在Linux系统中安装了tomcat的环境, 并且将tomcat设置为自动启动的服务(使用的是tomcat提供的jsvc工具)
  我在网上查了好久,都说是在bin目录的catalina.sh文件中的语句“cygwin=false”前加入类似 JAVA_OPTS="-Xms256m -Xmx512m -Xss1024K -XX:PermSize=128m -XX:MaxPermSize=256m" 的句子,但是我这么做了以后, 只能是在使用startup.sh启动的时候才会起作用,而不是在系统自动启动后起作用
  这个问题已经用了好长时间去解决了,但是找不到正确的解决办法.......,哪位大哥大姐帮忙解决下吧,小弟在这里谢过了
加载中
0
char1st
char1st
看下 /etc/init.d/ 下面有没有tomcat 文件,如果有,你应该知道下面怎么弄了。

0
小张java

引用来自“char1st”的评论

看下 /etc/init.d/ 下面有没有tomcat 文件,如果有,你应该知道下面怎么弄了。

之前也试过在自己创建的启动脚本中设置jvm的属性,但是我对Linux不熟悉,不知道该怎么设置,我试了试没起作用,我是在start部分设置的,如下(红颜色部分是我新加的):

start() {
    echo -n $"Starting Tomcat6: "
    # If you want to specify a user to run Tomcat.
    #increase the 'user $ TOMCAT_USER \' to the parameter list.
    $DAEMON_HOME/jsvc \
    -home $JAVA_HOME \
    -Dcatalina.home=$CATALINA_HOME \
    -Dcatalina.base=$CATALINA_BASE \
    -Djava.io.tmpdir=$TMP_DIR \
    -DJAVA_OPTS="-Xms256m -Xmx512m" \
    -wait 10 \
    -pidfile $PID_FILE \
    -outfile $CATALINA_HOME/logs/catalina.out \
    -errfile '&1' \
    $CATALINA_OPTS \
    -cp $CLASSPATH \
    org.apache.catalina.startup.Bootstrap
    echo "tomcat-6.0.41 has started successfully,************[ok]"
}

请给看看,谢谢你!

0
char1st
char1st
JAVA_OPTS="-Xms256m -Xmx512m"   写到JAVA_HOME下面  不是在start()里面的
返回顶部
顶部