senginx中怎么加载Modsecurity模块

小苏1106 发布于 2014/06/20 11:29
阅读 529
收藏 0

@InfoHunter 你好,想跟你请教个问题:

       我现在用的senginx版本是1.6.0,安装完成后在nginx.conf中的某个location中设置ModSecurityEnabled on;后一直报错,不能识别ModSecurityEnabled 。依照官网上关于ModSecurity的使用方法操作后,依然不能识别。

然后分别用1.5.13版本和1.6.0版本在编译安装时加上--with-modsecurity选项,如下图

这一步执行完成后出现很多错误信息,1.5.13和1.6.0错误信息一样如下图所以,之后再执行make或make install均报错,请问是哪一步有问题吗?



加载中
0
InfoHunter
InfoHunter
得装libcurl吧
InfoHunter
InfoHunter
@小苏1106 是的
小苏1106
果然是这样,感激不尽。不过它需要的依赖包还真多,呵呵
0
javadeveloper
javadeveloper
没用过,我也想知道。
返回顶部
顶部