activemq启动不了

白日梦想家 发布于 2014/06/08 17:50
阅读 6K+
收藏 0

系统是centos6.5minimal;用的包是apache-activemq-5.4.0-bin.tar;图片是日志,哪位大神帮忙看下咋回事?

加载中
0
横云断岭
貌似是没有配置host,到hosts文件里,把localhost, activemq.xml里的host都配置上,再看下。
0
白日梦想家
白日梦想家

 <broker xmlns="http://activemq.apache.org/schema/core" brokerName="loaclhost" dataDirectory="${activemq.base}/data" destroyApplicationContextOnStop="true">

是把标红的改为“mini”?

127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
这个是默认的hosts,需要改吗?

0
白日梦想家
白日梦想家

引用来自“hengyunabc”的评论

貌似是没有配置host,到hosts文件里,把localhost, activemq.xml里的host都配置上,再看下。
 <broker xmlns="http://activemq.apache.org/schema/core" brokerName="loaclhost" dataDirectory="${activemq.base}/data" destroyApplicationContextOnStop="true">


是把“localhost"改为“mini”?


127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
这个是默认的hosts,需要改吗?
0
横云断岭

那个brokerName不影响的,可以随便起个名字,在5.8是这样子的。

下面的Connector的配置是怎样的?建议在activemq的目录下搜索下mini。

0
乱世键客
乱世键客
不是很明显么?Failed to resolve localhost.
0
白日梦想家
白日梦想家

引用来自“乱世键客”的评论

不是很明显么?Failed to resolve localhost.
应该怎么配置呢?
0
白日梦想家
白日梦想家

引用来自“hengyunabc”的评论

那个brokerName不影响的,可以随便起个名字,在5.8是这样子的。

下面的Connector的配置是怎样的?建议在activemq的目录下搜索下mini。

我这个安装以后什么都没配置过  activemq目录里没有mini,我的主机名叫mini。是不是必须配置才能启动这个啊
0
kimmking
kimmking
配置文件发出来。 activemq.xml
0
白日梦想家
白日梦想家

引用来自“kimmking”的评论

配置文件发出来。 activemq.xml
--杯具 我昨天重装系统了 虚拟机打开以后配不上ip了,我刚才在另一台虚拟机上重装了一下activemq,又报的这个错[root@web101 data]# vim activemq.log 

2014-06-12 16:55:17,254 | WARN  | destroyApplicationContextOnStop parameter is deprecated, please use shutdown hooks instead | org.apache.activemq.xbean.XBeanBrokerService | main

你帮忙看一下,谢啦!系统centos5.10

activemq.xml没有改动过

<!--
    Licensed to the Apache Software Foundation (ASF) under one or more
    contributor license agreements.  See the NOTICE file distributed with
    this work for additional information regarding copyright ownership.
    The ASF licenses this file to You under the Apache License, Version 2.0
    (the "License"); you may not use this file except in compliance with
    the License.  You may obtain a copy of the License at
   
    http://www.apache.org/licenses/LICENSE-2.0
   
    Unless required by applicable law or agreed to in writing, software
    distributed under the License is distributed on an "AS IS" BASIS,
    WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
    See the License for the specific language governing permissions and
    limitations under the License.
-->
<beans
  xmlns="http://www.springframework.org/schema/beans"
  xmlns:amq="http://activemq.apache.org/schema/core"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans-2.0.xsd
  http://activemq.apache.org/schema/core http://activemq.apache.org/schema/core/activemq-core.xsd">


    <!-- Allows us to use system properties as variables in this configuration file -->
    <bean class="org.springframework.beans.factory.config.PropertyPlaceholderConfigurer">
        <property name="locations">
            <value>file:${activemq.base}/conf/credentials.properties</value>
        </property>      
    </bean>


    <!-- 
        The <broker> element is used to configure the ActiveMQ broker. 
    -->
    <broker xmlns="http://activemq.apache.org/schema/core" brokerName="localhost" dataDirectory="${activemq.base}/data" destroyApplicationContextOnStop="true">
 
        <!--
For better performances use VM cursor and small memory limit.
For more information, see:
            
            http://activemq.apache.org/message-cursors.html
            
            Also, if your producer is "hanging", it's probably due to producer flow control.
            For more information, see:
            http://activemq.apache.org/producer-flow-control.html
        -->
              
        <destinationPolicy>
            <policyMap>
              <policyEntries>
                <policyEntry topic=">" producerFlowControl="true" memoryLimit="1mb">
                  <pendingSubscriberPolicy>
                    <vmCursor />
                  </pendingSubscriberPolicy>
                </policyEntry>
                <policyEntry queue=">" producerFlowControl="true" memoryLimit="1mb">
                  <!-- Use VM cursor for better latency
                       For more information, see:
                       
                       http://activemq.apache.org/message-cursors.html
                       
                  <pendingQueuePolicy>
                    <vmQueueCursor/>
                  </pendingQueuePolicy>
                  -->
                </policyEntry>
              </policyEntries>
            </policyMap>
        </destinationPolicy> 
 
        
        <!-- 
            The managementContext is used to configure how ActiveMQ is exposed in 
            JMX. By default, ActiveMQ uses the MBean server that is started by 
            the JVM. For more information, see: 
            
            http://activemq.apache.org/jmx.html 
        -->
        <managementContext>
            <managementContext createConnector="false"/>
        </managementContext>


        <!-- 
            Configure message persistence for the broker. The default persistence
            mechanism is the KahaDB store (identified by the kahaDB tag). 
            For more information, see: 
            
            http://activemq.apache.org/persistence.html 
        -->
        <persistenceAdapter>
            <kahaDB directory="${activemq.base}/data/kahadb"/>
        </persistenceAdapter>
        
        
          <!--
            The systemUsage controls the maximum amount of space the broker will 
            use before slowing down producers. For more information, see:
            
            http://activemq.apache.org/producer-flow-control.html
             
        <systemUsage>
            <systemUsage>
                <memoryUsage>
                    <memoryUsage limit="20 mb"/>
                </memoryUsage>
                <storeUsage>
                    <storeUsage limit="1 gb"/>
                </storeUsage>
                <tempUsage>
                    <tempUsage limit="100 mb"/>
                </tempUsage>
            </systemUsage>
        </systemUsage>
-->
 
        <!-- 
            The transport connectors expose ActiveMQ over a given protocol to
            clients and other brokers. For more information, see: 
            
            http://activemq.apache.org/configuring-transports.html 
        -->
        <transportConnectors>
            <transportConnector name="openwire" uri="tcp://0.0.0.0:61616"/>
        </transportConnectors>


    </broker>


    <!-- 
        Uncomment to enable Camel
        Take a look at activemq-camel.xml for more details
         
    <import resource="camel.xml"/>
    -->


    <!-- 
        Enable web consoles, REST and Ajax APIs and demos
        Take a look at activemq-jetty.xml for more details 
    -->
    <import resource="jetty.xml"/>
    
</beans>

0
白日梦想家
白日梦想家

问题最终解决了  大神太忙了 都是点到为止  今天在一个群里聊天聊到了  贴在这给后来人用吧

vi /etc/hosts   

127.0.0.1  mini(mini是我的主机名)

返回顶部
顶部