lovej4Fensy 一个开源的java项目,使用了Maven ,怎么用Eclipse tomcat7 搭建并且可以在浏览器跑起来?

iCrany 发布于 2014/05/09 12:25
阅读 1K+
收藏 0

软件运行环境

  1. maven:Apache Maven 3.1.1   
  2. OS name: "windows 7", version: "6.1", arch: "x86", family: "windows"
  3. Java version: 1.7.0_15, vendor: Oracle Corporation
  4. Eclipse Version: Kepler Service Release 1
  5. Tomcat:apache-tomcat-7.0.47
  大家好,我想学习一下他的源代码,所以我下载了这个项目相关的两个文件,一个是Fensy 是他写的框架,一个是 lovej4Fensy下载地址为:小菜的粉丝 (ketayao) 我用了 mvn clean package -Dmaven.test.skip=true 命令把 那个框架 Fensy 打包成了一个jar包,并且修改了 lovej4Fensy 的pom.xml 的依赖

因为中途遇到了编码的问题以及一个logback-classic-1.0.13.jar 的读取出错问题,所以还修改了 lovej4Fensy 的 pom.xml 的这两个部分:
以及

    其他的地方都没有改过了,然后将 lovej4Fensy 使用 mvn clean package -Dmaven.test.skip=true 打包成了 war 包,放在了 tomcat7的webapp文件下面,在浏览器中输入相对应的 url 没有显示出来,尝试过添加 <welcome-list>到web.xml文件中,但是因为他使用的是模版引擎,我就默认的找了\WEB-INF\www\admin\index.ftl为 <welcome-list>的值,但是也是运行不了,刚学maven 参考书籍是 Maven权威指南 但是里面找不到我现在遇到的相关的问题,在此先谢谢各位了。

加载中
0
小菜的粉丝
小菜的粉丝
晚上帮你看看
就是康师傅
就是康师傅
你是怎么解决的?
0
就是康师傅
就是康师傅

com.ketayao.interceptor.CustomerInterceptor cannot be cast to com.ketayao.fensy.mvc.interceptor.Interceptor 

您好,这个报错 是因为什么 ?


返回顶部
顶部