qt在linux上和移植时用的到底是哪个qmake

浮伞一朵 发布于 2014/05/02 17:03
阅读 395
收藏 0
Qt
我最近用了下6410的开发板,按qt教程移植成功,有些地方很困惑,求解答。

1、在linux中,我先安装了qt-extended-4.4.3,也就是qtopia4,这个有什么用呢?按网上查的资料理解,是为了在linux中提供编译到目标板上可执行文件的库,对吗?

2、接着安装了qt/e4.7.1,我看过里面的build-all文件,配置中写了-embeded arm,那么这个意思就是所安装的qt也是用于提供编译到目标板的文件,用于目标板移植的文件,对吗?

3、接着我从ubuntu软件中心安装了qtcreator,然后随便弄了个小程序,在ubuntu中运行成功了。我困惑的就是这个地方,按照6410的qt教程来说,我是没有安装用于linux的qt库的,那为什么可以运行qt的程序?后来我查看了一下linux下的qmake版本,写的是using qt version 4.6.2,但是我没安装过qt4.6.2,难道说安装qtcreator的时候它都会自动帮忙装一个相应版本的qt?
加载中
返回顶部
顶部