maven-bundle-plugin插件打包的问题?

西夏一品堂 发布于 2015/08/21 10:42
阅读 1K+
收藏 0

maven-bundle-plugin插件是felix出的

我在插件里面是这样配置的

<Import-Package>org.osgi.framework</Import-Package>

但是,生成出来的东西是这样的:

Import-Package: org.osgi.framework;version="[1.8,2)"

如果控制插件,不要乱加东西,我没有配置version,为啥就偷偷加上了。

请问,这个问题如何解决

加载中
0
孤好梦中X人
孤好梦中X人

maven-bundle-plugin 插件会严格按照你pom.xml配置依赖的版本生成指定的版本号

插件生成这个Import-Package: org.osgi.framework;version="[1.8,2)"是因为你pom.xml配置osgi的版本太高了,导致的。

改一下pom.xml的配置就可以了

0
巴林的狗尾草
巴林的狗尾草
请再描述的清楚一点儿行么?不管你加不加version maven都会给你一个version的啊。继承过来的,你打maven dependency-tree看看怎么回事儿。
巴林的狗尾草
巴林的狗尾草
回复 @西夏一品堂 : 那你自己指定一个啊。。。我去,maven的dependency的加载机制你仔细搞搞明白自然就会了。
西夏一品堂
西夏一品堂
我现在就是想让它不要加,因为它加的是错误的。
0
独孤青冥
独孤青冥

像中央库、插件库之类的东西一般会自己加上版本号的,如果没有指定版本,就会指向当前最新版本,如果已经执行过,那么版本号就固定在当前版本了,这是为了避免兼容性问题

我不是玩java的哈,我是写ruby的,就我所知,ruby的gem包就是这个样子的

OSCHINA
登录后可查看更多优质内容
返回顶部
顶部