javax.net.ssl.SSLException: Unsupported record version SSLv2Hello

西夏一品堂 发布于 2015/10/14 21:42
阅读 7K+
收藏 0

开源之夏第三届火热来袭,高校学生参与赢万元奖金!>>>

在jdk1.7下是正常的,jdk1.8会报出以下异常:

javax.net.ssl.SSLException: Unsupported record version SSLv2Hello 

报错信息如下:

Caused by: [javax.net.ssl.SSLException - Unsupported record version SSLv2Hello] 
javax.net.ssl.SSLException: Unsupported record version SSLv2Hello 
at sun.security.ssl.InputRecord.checkRecordVersion(InputRecord.java:552)[:1.8.0_45] 
at sun.security.ssl.InputRecord.readV3Record(InputRecord.java:565)[:1.8.0_45] 
at sun.security.ssl.InputRecord.read(InputRecord.java:529)[:1.8.0_45] 
at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:961)[:1.8.0_45] 
at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1363)[:1.8.0_45] 
at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1391)[:1.8.0_45] 
at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1375)[:1.8.0_45]



请问,如何解决

加载中
0
o
o初_阳o
该评论暂时无法显示,详情咨询 QQ 群:点此入群
o
o初_阳o
@西夏一品堂 使用java自带的AES CTR128加密,不用openssl,可以的
西夏一品堂
西夏一品堂
我的问题也没有解决
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部