超级崩溃ubuntu无法安装Rails3,gem install rails无法执行

Rayay 发布于 2011/08/19 22:12
阅读 3K+
收藏 0
在ubuntu11下,试过多种方法,安装Rails的时候均出现一样错误,现在已经使用RVM管理Ruby。详细安装方法,按照http://blog.sina.com.cn/s/blog_695f60580100xbn1.html这个网址进行。
#This loads RVM into a shell session已经加入.bashrc文件中了。


RVM版本:ray@ray-965P-S3:~$ rvm -v

rvm 1.7.2 by Wayne E. Seguin (wayneeseguin@gmail.com) [https://rvm.beginrescueend.com/]

Ruby版本:ray@ray-965P-S3:~$ ruby -v
ruby 1.9.2p290 (2011-07-09 revision 32553) [i686-linux]


RubyGems Environment:
- RUBYGEMS VERSION: 1.8.6
- RUBY VERSION: 1.9.2 (2011-07-09 patchlevel 290) [i686-linux]
- INSTALLATION DIRECTORY: /home/ray/.rvm/gems/ruby-1.9.2-p290
- RUBY EXECUTABLE: /home/ray/.rvm/rubies/ruby-1.9.2-p290/bin/ruby
- EXECUTABLE DIRECTORY: /home/ray/.rvm/gems/ruby-1.9.2-p290/bin
- RUBYGEMS PLATFORMS:
- ruby
- x86-linux
- GEM PATHS:
- /home/ray/.rvm/gems/ruby-1.9.2-p290
- /home/ray/.rvm/gems/ruby-1.9.2-p290@global
- GEM CONFIGURATION:
- :update_sources => true
- :verbose => true
- :benchmark => false
- :backtrace => false
- :bulk_threshold => 1000
- REMOTE SOURCES:
- http://rubygems.org/


ray@ray-965P-S3:~$ which ruby
/home/ray/.rvm/rubies/ruby-1.9.2-p290/bin/ruby

上面是很多配置问题,RUBY,RVM之类的都安装成功了,唯独Rails安装的时候总是出问题。问题如下:

ray@ray-965P-S3:~$ gem install rails
ERROR: While executing gem ... (Gem::DependencyError)
Unable to resolve dependencies: rails requires activesupport (= 3.0.9), actionpack (= 3.0.9), activerecord (= 3.0.9), activeresource (= 3.0.9), actionmailer (= 3.0.9), railties (= 3.0.9), bundler (~> 1.0)
ray@ray-965P-S3:~$ rails -v
程序“rails”尚未安装。 您可以使用以下命令安装:sudo apt-get install rails

已经尝试了多种方法无法解决,已经弄了好几天了,都停留在这里。现在想问问谁知道如何解决这种问题,希望的到答案。
加载中
0
witgo
witgo
下载下了手工安装
R
Rayay
rails3没有在线下载的啊~rubygems.org的都是2的版本的~
0
40hood
40hood

ruby -v
gem -v

0
witgo
witgo

不会啊,您咋找的啊?

https://rubygems.org/gems/rails

witgo
witgo
@Rayay : 对,有点麻烦。
R
Rayay
@witgo : 那下载下来的安装就要所有的包都下载下来安装了?
witgo
witgo
@Rayay : 缺少gem 安装缺少的gem 以此类推
R
Rayay
@witgo : 利用CTRL+L获取的路径; ray@ray-965P-S3::~$ gem install /home/ray/rails-3.0.10.gem ERROR: While executing gem ... (Gem::DependencyError) 依然存在错误
witgo
witgo
@Rayay : 绝对路径吗?
下一页
0
40hood
40hood

给你一个连接

Best Practice of Installing Ruby on Rails on Ubuntu 11.04 ( 2011 version ) | Blog.XDite.net

http://blog.xdite.net/?p=2348

0
绿海荡舟
绿海荡舟
试一下Ruby 1.9.3。记得好像Ruby1.9.2有问题。不推荐使用了。
返回顶部
顶部