求救:centos只能访问内网不能访问外网,以并且出现执行route 命令后的默认网关很慢才出现

.有人 发布于 2011/08/01 10:09
阅读 10K+
收藏 1

 Q:centos安装好后,进行了IP及NFS和GW设置,可以在局域网用SSH登录,但是本机只能访问内网不能访问外网,以并且出现执行route 命令后的默认网关很慢才出现

 [root@localhost ~]# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
169.254.0.0     *               255.255.0.0     U     0      0        0 eth0
default         192.168.1.1     0.0.0.0         UG    0      0        0 eth0  <------------------这条记录将近要等20秒才会出来 

[root@localhost ~]# ping 192.168.1.237
PING 192.168.1.237 (192.168.1.237) 56(84) bytes of data.
64 bytes from 192.168.1.237: icmp_seq=1 ttl=128 time=0.349 ms
64 bytes from 192.168.1.237: icmp_seq=2 ttl=128 time=0.470 ms
[root@localhost ~]# ping www.baidu.com
ping: unknown host www.baidu.com
 
[root@localhost ~]# ifconfig (以下信息被部分删节)
eth0      Link encap:Ethernet  HWaddr 00:10:5C:EA:1A:38
          inet addr:192.168.1.246  Bcast:192.168.1.255  Mask:255.255.255.0

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0

以下我的网络配制:
windows下IP配制,可以访问外网
 

CENTOS配制
[root@localhost ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:10:5C:EA:1A:38
          inet addr:192.168.1.246  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:18287 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2990 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1977631 (1.8 MiB)  TX bytes:430445 (420.3 KiB)
          Interrupt:169 Base address:0x2000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:14244 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14244 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:16075426 (15.3 MiB)  TX bytes:16075426 (15.3 MiB)


[root@localhost ~]# more /etc/sysconfig/network-scripts/ifcfg-eth0
# Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+
DEVICE=eth0
BOOTPROTO=static
HWADDR=00:10:5C:EA:1A:38
ONBOOT=yes
NETMASK=255.255.255.0
IPADDR=192.168.1.246
NETWORK=192.168.1.0

[root@localhost ~]# more /etc/sysconfig/network
NETWORKING=yes
NETWORKING_IPV6=no
HOSTNAME=localhost.localdomain
GATEWAY=192.168.1.1

[root@localhost ~]# more /etc/resolv.conf
search localdomain
nameserver 202.101.226.68
nameserver 202.101.224.69

[root@localhost ~]# service network restart
Shutting down interface eth0:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:                                [  OK  ]
 

 
 

以下是问题补充:

@.有人:防火墙已关闭 [root@localhost ~]# service iptables stop Flushing firewall rules: [ OK ] Setting chains to policy ACCEPT: filter [ OK ] Unloading iptables modules: [ OK ] [root@localhost ~]# iptables -vnL Chain INPUT (policy ACCEPT 21 packets, 1819 bytes) pkts bytes target prot opt in out source destination Chain FORWARD (policy ACCEPT 0 packets, 0 bytes) pkts bytes target prot opt in out source destination Chain OUTPUT (policy ACCEPT 13 packets, 1628 bytes) pkts bytes target prot opt in out source destination (2011/08/01 10:24)
加载中
0
华宰
华宰

试试先把防火墙关掉看看呢?

service iptables stop

.
.有人
感谢你的回复,关闭还是不行。 [root@localhost ~]# iptables -vnL Chain INPUT (policy ACCEPT 21 packets, 1819 bytes) pkts bytes target prot opt in out source destination Chain FORWARD (policy ACCEPT 0 packets, 0 bytes) pkts bytes target prot opt in out source destination Chain OUTPUT (policy ACCEPT 13 packets, 1628 bytes) pkts bytes target prot opt in out source destination
0
G
GuanChunhong

这个问题解决了吗?我也遇到了同样的问题。

如已解决,希望给我答案。我的email:wanwanabc@hotmail.co.jp

0
e
edwardking

主要是放火墙和iptables 配置, 注意NAT   ,还就是XP网络使用服务器网关,有问题联系

0
w
wu_wenyao
这个问题我也遇到了并解决了,是DNS的问题,设一个内网的DNS或把内网DNS放在resolv.conf最前面就可以了
刘旱魁
刘旱魁
内网dns是什么
0
娃娃哇
娃娃哇

/etc/sysconfig/network-scripts  目录下新件了 文件  route-eth0

添加内容  via 192.168.1.1

重启网络:service network restart  然后ping www.baidu.com 

问题原因:系统缺少路由 配置

说明: 亲测.实验成功! - -

娃娃哇
娃娃哇
@刘旱魁 这个ip是网关
刘旱魁
刘旱魁
1470143877@qq.com 怎么解决的,求指教。我的不行, via ip 这个ip从哪获取的
0
刘旱魁
刘旱魁
1470143877@qq.com 怎么解决的,求指教。我的不行, via  ip  这个ip从哪获取的
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部