Nagios中的一个插件问题,急急急……

yearn 发布于 2011/09/23 16:45
阅读 465
收藏 0

Nagios已经安装成功,然后在安装一个插件nrpe的时候出现如下错误 

tar -xzvf nrpe-2.12.tar.gz
cd nrpe-2.12

./configure --enable-ssl --enable-command-args   或者./configure && make all

结果一样,求解

加载中
0
Z
ZYud

.h .so是分别在两个RPM包中的.

.so 在openssl

.h是在openssl-devel

之前的提示是缺少.h,安装上之后就可以正常编译了.

yearn
yearn
不行,提示openssl-devel有依赖
0
鉴客
鉴客
安装 openssl 包啊
yearn
yearn
不行呀 哦yum install openssl以后 重新安装nrpe 还是提示这个错误
0
鉴客
鉴客

你使用 yum 安装的 openssl 是不包含源码的,没有 openssl 的头文件。

下载个源码包来编译安装,然后看看 configure 的参数怎么指定 openssl 的源码位置

yearn
yearn
麻烦看一下,最好给个详细解释
0
yearn
yearn
get http://www.openssl.org/source/openssl-0.9.7g.tar.gz
tar zxvf openssl-0.9.7g.tar.gz
cd  openssl-0.9.7g
./config --prefix=/usr/local/ssl  --openssldir=/usr/local/ssl  shared  zlib
make 
make install
ln -s /usr/local/ssl /usr/lib/ssl
这样编译的还是不行你给指点一下
0
Z
ZYud

引用来自“鉴客”的答案

安装 openssl 包啊
openssl-devel
yearn
yearn
安装过了 可是还是这样啊,是不是安装完之后配置一下呀?
0
yearn
yearn
error: Failed dependencies:
        krb5-devel is needed by openssl-devel-0.9.8e-12.el5_4.6.i386
        openssl = 0.9.8e-12.el5_4.6 is needed by openssl-devel-0.9.8e-12.el5_4.6.i386
0
yearn
yearn

引用来自“ZYud”的答案

.h .so是分别在两个RPM包中的.

.so 在openssl

.h是在openssl-devel

之前的提示是缺少.h,安装上之后就可以正常编译了.

.h .so是分别在两个RPM包中的.

.so 在openssl

.h是在openssl-devel

之前的提示是缺少.h,安装上之后就可以正常编译了.

确实少一个openssl-devel 包   安装这个包的需要用yum 安装  因为用rpm会有依赖性

返回顶部
顶部